No auth provider found, even though it is installed according to docs

I’m having trouble with getting any oauth tokens from github. I have followed and reread the docs at Use OAuth provider tokens on your site | Netlify Docs multiple times. Here you can see my oauth provider setup in the site configuration

When browsing to Netlify Authorization, I get the standard “no auth provider found” response.

The repo is under an org. Idk if that should make any difference, I couldn’t find anything about it in the docs. I have tried registering the oauth app both under the org and under my own github account.

On the picture at step 3 on Use OAuth provider tokens on your site | Netlify Docs, it doesnt show the “enable device flow” option when creating the application. In any case, I’ve tried both with and without it.

If I understand correctly, it shouldnt be relevant, but I’m trying to use Static CMS - a fork of netlify/decap cms. I am 99% sure the github backend works the same there as it does for netlify/decap. The docs for the github backend are the same aswell.

For Static CMS, the OAuth settings are here:<site-name>/configuration/identity#external-providers, not the ones you’re using.

Hmm, isnt netlify identity only needed when you want to use git-gateway though? I’m trying to use just the github backend.

I added github to external providers and git-gateway in the identity settings, but I still get the same message:

Correct me if I’m wrong, but shouldn’t Netlify Authorization redirect me to github, if I have it setup correctly in Netlify App, regardless of what I’m using it for?

I found the problem. The site_id query parameter should not include “https://”. Manually removing it from the url solves the issue. Seems like this infact had to do with staticcms, altough it’s probably due to a faulty config on my part.

oh that’s awesome thanks for coming back and sharing your solution!