Next.js Initial Deploy fails on yarn install (node-sass)

Hi all,

I’ve just signed up and tried to deploy my next.js application. It has successfully deployed numerous times on vercel so I was a bit confused why it failed here.

The issue seems to be on the yarn install and it seems to die around the make call in node-sass.

I originally had the default yarn build and tried out next build but it seems to fail before even that.

Site Name:
Build: Netlify App
Build Settings:

Package.json: looter-io/package.json at main · nrodriguez/looter-io · GitHub

Any help is appreciated. Thanks!

Welcome to the forums @JustNeph

I am not sure why node-gyp always seems to produce the same error recently. The workout I have worked out is to downgrade node to v14.

Set the NODE_VERSION environment variable to v14.17.5 (Site Settings > Build & Deploy > Environment) the trigger a deploy from the deploys page.

That seemed to work. I checked my local and I was indeed running node v14.17.0 so that’s why I didn’t see the same issue locally. Weird that it fails on node v16 though.

Either way, I appreciate the help as the deploy succeeded! Thanks you!!