Netlify sending POST to client url instead of server url

FE: Netlify
BE: Firebase functions/db
Auth: Firebase

Goal: Successfully login


  1. Everything works fine in local environment.
  2. When deployed to Netlify however,
  • It lands on login page, no issues
  • when trying to login, I get a 404 POST
  • I would expect the POST to have my backend API url (firebase), but it has my front-end url instead.

Is there a setting I’ve missed somewhere? I do have the proxy set to my firebase url in my FE package.json.


Finally figured this one out.

Just in case they may help someone in the future, here’s what my issues were:

  1. Cors not setup on BE.
  2. FE API urls were just /login. They needed to contain the full BE url prefix to work on netlify, even though these were not needed to work locally. Not sure why there.

Glad you were able to solve that. Appreciate the update on resolution!