Netlify returns 404 for SSR Nuxt website

Site name:


My website is a Nuxt 3 Vue.js app configured with SSR enabled. Here is the full repo : GitHub - polysource-projects/refweek: Simulateur d'emploi du temps de BA1

When I navigate to the Netlify website, it returns a 404 not found error. What can I do to fix it?

Create a _redirects file here: refweek/public at main · epfl-tools/refweek ( with the content:

/* /.netlify/functions/server 200

Thank you for your answer! This doesn’t seem to have worked…

You’re uploading the wrong folder:

Starting to deploy site from '.nuxt/dist'

That’s why I wondered why the redirect is not being generated as Nuxt automatically creates that. The publish folder should probably be dist.

You may remove the _redirects file as that would be automatically created by Nuxt.


I had the same issue! The default netlify picked was ‘.nuxt/dist’ which made sense to me…

Hi! I have the same issue with my Nuxt 3 app : 1.
I’m sorry but I don’t understand what to do to solve this… Can you tell me more please?

Thank you very much :slight_smile:

:wave: @authie.maxime

It appears you were able to get things sorted as I’m not seeing 404s on your site. Let us know if you still need help!

Hi audrey, would you mind explaining what I need to do in my site deploy settings? I am having the same issue

what site is experiencing this?

follow this configuration, for me its worked
Publish directory : dist

thanks for sharing this with the community!

We were a little confused by this answer. Should it be /.nuxt/dist - ? (No).

Just to help clarify (as of this date)

Publish directory: dist

(even that key ^ here is confusing!)

So, just “dist” (and in our case we were using pnpm build