Netlify Large Media error: Repository or object not found

Hi, this is for my Netlify site name dirtystylus-2020

I’ve had Netlify Large Media implemented on my site for ~4 years, today it stopped working with the following error:

batch response: Repository or object not found: https://[SITE ID].netlify.com/.netlify/large-media/objects/batch
Check that it exists and that you have proper access to it

I have tried some of the suggestions in this thread: A can't upload image to lfs in netlify

  • I updated Netlify CLI
  • I logged out and then back in to Netlify CLI
  • I updated Netlify Large Media via netlify lm:install
  • I tried pushing using git lfs push --all origin

So far I’m still getting the same error.

Running netlify lm:info returns this:

✔ Checking Git version [Git-143)]
✔ Checking Git LFS version [3.4.0]
✔ Checking Git LFS filters
✔ Checking Netlify's Git Credentials version [0.1.11]

Any suggestions on what to try next? ty

Quick update: to rule out a connection to my recent Eleventy upgrade (v0.12 → v1.0.1) I spun up a branch, rolled back to the last pre-1.01 commit, and attempted to push. Got the same error.

Hi @dirtystylus,

On a related note, I attempted to push changes this morning, but I got: your repository has timed out after 1 minutes.

Also, when generating a sitemap, I get:
There was an error while accessing the URL specified:

However, my domain www.vanas.ca it’s up and running.

Similar behavior to what you’re experiencing.

@pochat Oh, interesting—was it your netlify site ID URL that it couldn’t reach?

Here is my Netlify URL
https://vanascanada.netlify.app

It sounds like this issue below:

Would you please take a look at this section above and let us know if that helps?

Ran: git config -l | grep netlify

Output:

include.path=/Users/markllobrera/.netlify/helper/git-config
credential.helper=netlify
include.path=/Users/markllobrera/Library/Preferences/netlify/helper/git-config
credential.helper=netlify
lfs.https://0d44d6dd-bf27-49da-b942-66965a018df9.netlify.com/.netlify/large-media.access=basic
lfs.https://0d44d6dd-bf27-49da-b942-66965a018df9.netlify.com/.netlify/large-media.locksverify=false

@luke This morning I tried running:

netlify lm:setup --debug

And got this output:

[project.ts]: detectFrameworks
[project.ts]: detectBuildSystem
[project.ts]: detectWorkspaces
[project.ts]: detectPackageManager
[project.ts]: detectFrameworksInPath - undefined

❯ Initial build environment
config: /Users/markllobrera/git-workspace/mark-llobrera/netlify.toml
context: dev
cwd: /Users/markllobrera/git-workspace/mark-llobrera
featureFlags: []
mode: cli
repositoryRoot: /Users/markllobrera/git-workspace/mark-llobrera
siteId: 0d44d6dd-bf27-49da-b942-66965a018df9

❯ UI build settings
baseRelDir: true
build:
  base: /
  command: eleventy --incremental
  publish: _site

❯ Resolved build environment
branch: master
buildDir: /Users/markllobrera/git-workspace/mark-llobrera
configPath: /Users/markllobrera/git-workspace/mark-llobrera/netlify.toml
context: dev
env:
  - NETLIFY_LFS_ORIGIN_URL
  - DEPLOY_ID
  - BUILD_ID
  - REPOSITORY_URL
  - NETLIFY_LOCAL
  - HEAD
  - COMMIT_REF
  - CACHED_COMMIT_REF
  - PULL_REQUEST
  - LANG
  - LANGUAGE
  - LC_ALL
  - GATSBY_TELEMETRY_DISABLED
  - NEXT_TELEMETRY_DISABLED

❯ Resolved config
build:
  base: /Users/markllobrera/git-workspace/mark-llobrera
  command: eleventy --incremental
  commandOrigin: ui
  publish: /Users/markllobrera/git-workspace/mark-llobrera/_site
  publishOrigin: ui
redirects:
  - from: /reading/daredevil-know-fear-v1/
    to: /reading/daredevil-v1-know-fear/
  - from: /:year/:month/:date/:slug
    status: 301
    to: /posts/:slug
redirectsOrigin: config
✖ Netlify Large Media is already installed for dirtystylus-2020
◼ Configuring Git LFS for this site

Not sure if that last line from the debug output is a clue to a deeper issue, or if it skipped it because NLM was already installed

@luke Any other suggestions? I tried to investigate this a different way by cloning my site repo fresh from Github into a new directory, which should leave me in a state from the last successful deploy. I got this error:

Cloning into 'markllobrera-eleventy'...
remote: Enumerating objects: 8558, done.
remote: Counting objects: 100% (2026/2026), done.
remote: Compressing objects: 100% (1284/1284), done.
remote: Total 8558 (delta 785), reused 1920 (delta 702), pack-reused 6532
Receiving objects: 100% (8558/8558), 56.98 MiB | 4.01 MiB/s, done.
Resolving deltas: 100% (3553/3553), done.
Downloading img/mark-portrait-202108.jpg (242 KB)
Error downloading object: img/mark-portrait-202108.jpg (5f6e298): Smudge error: Error downloading img/mark-portrait-202108.jpg (5f6e298852b09bd9fef426b58af78d5cc8e43a596b002e9090da84d43b89d7d5): batch response: Repository or object not found: https://0d44d6dd-bf27-49da-b942-66965a018df9.netlify.com/.netlify/large-media/objects/batch
Check that it exists and that you have proper access to it

Errors logged to '/Users/markllobrera/git-workspace/markllobrera-eleventy/.git/lfs/logs/20240509T095231.056297.log'.
Use `git lfs logs last` to view the log.
error: external filter 'git-lfs filter-process' failed
fatal: img/mark-portrait-202108.jpg: smudge filter lfs failed
warning: Clone succeeded, but checkout failed.
You can inspect what was checked out with 'git status'
and retry with 'git restore --source=HEAD :/'

I then went to check the Large Media file list on Netlify for my site, and that file does exist (created 3 years ago):
img/mark-portrait-202108.jpg, with that hash 5f6e298852b09bd9fef426b58af78d5cc8e43a596b002e9090da84d43b89d7d5

This seems to rule out this being related to new files that my repo was trying to track. (Or at least it isn’t strictly related to new media assets Git LFS was trying to track

Would you prefer to remove Large Media from your site? It doesn’t seem to provide any additional benefits now with the Image CDN.

I’ll eventually migrate to the new Image CDN but would love help seeing if my NLM instance is properly configured and responding properly, because it doesn’t seem to be connected to my git authentication helper

Hi, @dirtystylus. I opened a support ticket for this as I’m going to ask for some details that might not be safe to post publicly. Would you please check for an email from us about support ticket # 255008 and reply to that email to continue troubleshooting privately?