Netlify Large Media cannot be activated

Hi guys!

I’ve been trying to get netlify large media to work with in the last 2 days, and tried every possible combination that has been mentioned in other support threads, sadly to no avail.

I was able to complete the following:

  • enable netlify large media in my local repo (on macbook and with iterm/zsh) as stated in the docs: Large Media setup | Netlify Docs
  • I also did the part with the migration, because the repository already contained most of the full-size images, which needed to be converted to use the large media feature

locally, things are looking ok - when I run netlify lm:install it shows:

  ✔ Checking Git version [2.26.0]
  ✔ Checking Git LFS version [2.13.2]
  ✔ Checking Git LFS filters
  ✔ Installing Netlify's Git Credential Helper for Mac OS X
  ✔ Configuring Git to use Netlify's Git Credential Helper

and git lfs track shows:

static/*.jpg (.gitattributes)
static/*.png (.gitattributes)

and git lfs ls-files lists all the images contained in the repository correctly.

but, upon pushing (also with git push --force-with-lease) the images do not get added to large media, also the large media tab on the netlify account stays inactive, not showing anything than the default text.

now, when I do add a new picture locally to the repository, and commit and push it, the build on netlify is failing with the error (9fe1e45): Smudge error: Error downloading …but the files are all actually accessible on the repository and do say “Stored with Git LFS” on github, so I guess they are just pointers by now?

I hope this information is complete enough to get this further – I also noticed that when pushing commits via GUI (tower app) it shows an error message git: 'credential-netlify' is not a git command although when pushing via console/iterm, this error does not show. and I am connected to netlify CLI locally.

PS. the current website is connected to CMS – forestry also does have an option to connect to netlify large media feature Storing Uploads With Netlify Large Media | but I have not activated this yet, as I’m trying to get it working manually first within the repository and as the large media tab/feature needs to be activated on netlify first for it to actually work. hope that is making sense this way (:

thanks for your help,

I have a new error that might actually explain why netlify lm might not be working properly. if I run netlify lm:setup again locally, it throws this:

Logging into your Netlify account... Opening TypeError: Cannot read property 'slug' of undefined

so it looks like it cannot activate lm on this site after all, and all subsequent setup or uploads are silently failing therefore?

seems to be related to this issue, currently open: `netlify lm:setup` crashes · Issue #514 · netlify/cli · GitHub

finally! got it working. with the solution in this post: Cant push after trying to setup large media - #11 by alecazam

In my case, config.json did exist under ~/.netlify, but it was missing a bunch of fields that were present in ~/Library/Preferences/netlify/config.json. So I replaced the ~/netlify copy with the ~/Library/Preferences/ one, and re-ran netlify lm:setup . This time, the command ran successfully and created the .lfsconfig, finally.

all files now showing up on large media :slight_smile: