Netlify functions file upload failes

SITE: brevisvelox-ai2.netlify.app

There seems to be an issue with functions file. There is continuos deployment from feature branch on github. Previous builds worked just fine, there were no changes on the functions file, changes were made elsewhere, suddenly the build hangs on “Finished processing build request in …”

9:41:07 PM: build-image version: 524714d1a66d1a967316f5c39465e22c77fdd56c (focal)
9:41:07 PM: build-image tag: v4.16.0
9:41:07 PM: buildbot version: ccca89b58bb45671b9608069deb629f8ca866189
9:41:07 PM: Fetching cached dependencies
9:41:07 PM: Starting to download cache of 703.4MB
9:41:13 PM: Finished downloading cache in 5.608152807s
9:41:13 PM: Starting to extract cache
9:41:17 PM: Finished extracting cache in 4.287242124s
9:41:17 PM: Finished fetching cache in 10.002850488s
9:41:17 PM: Starting to prepare the repo for build
9:41:17 PM: Preparing Git Reference refs/heads/feature/research-styling
9:41:18 PM: Parsing package.json dependencies
9:41:19 PM: Different publish path detected, going to use the one specified in the Netlify configuration file: 'frontend/research/dist' versus 'dist' in the Netlify UI
9:41:19 PM: Different functions path detected, going to use the one specified in the Netlify configuration file: 'frontend/research/functions' versus '' in the Netlify UI
9:41:20 PM: Section completed: initializing
9:41:20 PM: Starting build script
9:41:20 PM: Installing dependencies
9:41:20 PM: Python version set to 2.7
9:41:20 PM: Started restoring cached node version
9:41:21 PM: Finished restoring cached node version
9:41:21 PM: v16.19.0 is already installed.
9:41:21 PM: Now using node v16.19.0 (npm v8.19.3)
9:41:21 PM: Enabling node corepack
9:41:21 PM: Started restoring cached build plugins
9:41:21 PM: Finished restoring cached build plugins
9:41:21 PM: Attempting ruby version 2.7.2, read from environment
9:41:22 PM: Using ruby version 2.7.2
9:41:22 PM: Using PHP version 8.0
9:41:22 PM: Started restoring cached yarn cache
9:41:25 PM: Finished restoring cached yarn cache
9:41:25 PM: No yarn workspaces detected
9:41:25 PM: Started restoring cached node modules
9:41:25 PM: Finished restoring cached node modules
9:41:25 PM: Installing NPM modules using Yarn version 1.22.19
9:41:25 PM: yarn install v1.22.19
9:41:25 PM: [1/4] Resolving packages...
9:41:26 PM: success Already up-to-date.
9:41:26 PM: Done in 0.50s.
9:41:26 PM: NPM modules installed using Yarn
9:41:26 PM: Started restoring cached go cache
9:41:26 PM: Finished restoring cached go cache
9:41:27 PM: go version go1.19.4 linux/amd64
9:41:27 PM: /opt/build-bin/run-build-functions.sh: line 1034: /opt/buildhome/.gimme/env/go1.19.x.linux.amd64.env: No such file or directory
9:41:27 PM: Detected 1 framework(s)
9:41:27 PM: "vue" at version "4.5.6"
9:41:27 PM: Installing missing commands
9:41:27 PM: Verify run directory
9:41:29 PM: ​
9:41:29 PM: ────────────────────────────────────────────────────────────────
9:41:29 PM:   Netlify Build                                                 
9:41:29 PM: ────────────────────────────────────────────────────────────────
9:41:29 PM: ​
9:41:29 PM: ❯ Version
9:41:29 PM:   @netlify/build 29.1.2
9:41:29 PM: ​
9:41:29 PM: ❯ Flags
9:41:29 PM:   baseRelDir: true
9:41:29 PM:   buildId: 639cd791d4b5fc000997e0c9
9:41:29 PM:   deployId: 639cd791d4b5fc000997e0cb
9:41:29 PM: ​
9:41:29 PM: ❯ Current directory
9:41:29 PM:   /opt/build/repo/frontend/research
9:41:29 PM: ​
9:41:29 PM: ❯ Config file
9:41:29 PM:   /opt/build/repo/frontend/research/netlify.toml
9:41:29 PM: ​
9:41:29 PM: ❯ Context
9:41:29 PM:   production
9:41:29 PM: ​
9:41:29 PM: ────────────────────────────────────────────────────────────────
9:41:29 PM:   1. Build command from Netlify app                             
9:41:29 PM: ────────────────────────────────────────────────────────────────
9:41:29 PM: ​
9:41:29 PM: $ npm run build
9:41:29 PM: > researchpages@0.1.0 build
9:41:29 PM: > vue-cli-service build
9:41:29 PM: -  Building for production...
9:41:31 PM: Browserslist: caniuse-lite is outdated. Please run:
9:41:31 PM: npx browserslist@latest --update-db
9:41:31 PM: Why you should do it regularly:
9:41:31 PM: https://github.com/browserslist/browserslist#browsers-data-updating
9:41:32 PM: Browserslist: caniuse-lite is outdated. Please run:
9:41:32 PM: npx browserslist@latest --update-db
9:41:32 PM: Why you should do it regularly:
9:41:32 PM: https://github.com/browserslist/browserslist#browsers-data-updating
9:41:34 PM: Browserslist: caniuse-lite is outdated. Please run:
9:41:34 PM:   npx browserslist@latest --update-db
9:41:34 PM:   Why you should do it regularly: https://github.com/browserslist/browserslist#browsers-data-updating
9:41:34 PM: Browserslist: caniuse-lite is outdated. Please run:
9:41:34 PM: npx browserslist@latest --update-db
9:41:34 PM: Why you should do it regularly:
9:41:34 PM: https://github.com/browserslist/browserslist#browsers-data-updating
9:41:36 PM: Browserslist: caniuse-lite is outdated. Please run:
9:41:36 PM: npx browserslist@latest --update-db
9:41:36 PM: Why you should do it regularly:
9:41:36 PM: https://github.com/browserslist/browserslist#browsers-data-updating
9:41:36 PM: Browserslist: caniuse-lite is outdated. Please run:
9:41:36 PM: npx browserslist@latest --update-db
9:41:36 PM: Why you should do it regularly:
9:41:36 PM: https://github.com/browserslist/browserslist#browsers-data-updating
9:41:36 PM: Browserslist: caniuse-lite is outdated. Please run:
9:41:36 PM: npx browserslist@latest --update-db
9:41:36 PM: Why you should do it regularly:
9:41:36 PM: https://github.com/browserslist/browserslist#browsers-data-updating
9:41:36 PM: Browserslist: caniuse-lite is outdated. Please run:
9:41:36 PM: npx browserslist@latest --update-db
9:41:36 PM: Why you should do it regularly:
9:41:36 PM: https://github.com/browserslist/browserslist#browsers-data-updating
9:41:36 PM: Browserslist: caniuse-lite is outdated. Please run:
9:41:36 PM: npx browserslist@latest --update-db
9:41:36 PM: Why you should do it regularly:
9:41:36 PM: https://github.com/browserslist/browserslist#browsers-data-updating
9:41:36 PM: Browserslist: caniuse-lite is outdated. Please run:
9:41:36 PM: npx browserslist@latest --update-db
9:41:36 PM: Why you should do it regularly:
9:41:36 PM: https://github.com/browserslist/browserslist#browsers-data-updating
9:41:36 PM: Browserslist: caniuse-lite is outdated. Please run:
9:41:36 PM: npx browserslist@latest --update-db
9:41:36 PM: Why you should do it regularly:
9:41:36 PM: https://github.com/browserslist/browserslist#browsers-data-updating
9:41:36 PM: Browserslist: caniuse-lite is outdated. Please run:
9:41:36 PM: npx browserslist@latest --update-db
9:41:36 PM: Why you should do it regularly:
9:41:36 PM: https://github.com/browserslist/browserslist#browsers-data-updating
9:41:36 PM: Browserslist: caniuse-lite is outdated. Please run:
9:41:36 PM: npx browserslist@latest --update-db
9:41:36 PM: Why you should do it regularly:
9:41:36 PM: https://github.com/browserslist/browserslist#browsers-data-updating
9:41:36 PM: Browserslist: caniuse-lite is outdated. Please run:
9:41:36 PM: npx browserslist@latest --update-db
9:41:36 PM: Why you should do it regularly:
9:41:36 PM: https://github.com/browserslist/browserslist#browsers-data-updating
9:41:38 PM: DEPRECATION WARNING: Using / for division outside of calc() is deprecated and will be removed in Dart Sass 2.0.0.
9:41:38 PM: Recommendation: math.div($spacer, 2) or calc($spacer / 2)
9:41:38 PM: More info and automated migrator: https://sass-lang.com/d/slash-div
9:41:38 PM:     ╷
9:41:38 PM: 302 │ $headings-margin-bottom:      $spacer / 2 !default;
9:41:38 PM:     │                               ^^^^^^^^^^^
9:41:38 PM:     ╵
9:41:38 PM:     node_modules/bootstrap/scss/_variables.scss 302:31  @import
9:41:38 PM:     src/assets/scss/bootstrap/_bootstrap.scss 3:9       @import
9:41:38 PM:     src/assets/scss/app.scss 2:9                        root stylesheet
9:41:38 PM: DEPRECATION WARNING: Using / for division outside of calc() is deprecated and will be removed in Dart Sass 2.0.0.
9:41:38 PM: Recommendation: math.div($input-padding-y, 2) or calc($input-padding-y / 2)
9:41:38 PM: More info and automated migrator: https://sass-lang.com/d/slash-div
9:41:38 PM:     ╷
9:41:38 PM: 497 │ $input-height-inner-quarter:            add($input-line-height * .25em, $input-padding-y / 2) !default;
9:41:38 PM:     │                                                                         ^^^^^^^^^^^^^^^^^^^^
9:41:38 PM:     ╵
9:41:38 PM:     node_modules/bootstrap/scss/_variables.scss 497:73  @import
9:41:38 PM:     src/assets/scss/bootstrap/_bootstrap.scss 3:9       @import
9:41:38 PM:     src/assets/scss/app.scss 2:9                        root stylesheet
9:41:38 PM: DEPRECATION WARNING: Using / for division outside of calc() is deprecated and will be removed in Dart Sass 2.0.0.
9:41:38 PM: Recommendation: math.div($custom-control-indicator-size, 2) or calc($custom-control-indicator-size / 2)
9:41:38 PM: More info and automated migrator: https://sass-lang.com/d/slash-div
9:41:38 PM:     ╷
9:41:38 PM: 567 │ $custom-switch-indicator-border-radius:         $custom-control-indicator-size / 2 !default;
9:41:38 PM:     │                                                 ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
9:41:38 PM:     ╵
9:41:38 PM:     node_modules/bootstrap/scss/_variables.scss 567:49  @import
9:41:38 PM:     src/assets/scss/bootstrap/_bootstrap.scss 3:9       @import
9:41:38 PM:     src/assets/scss/app.scss 2:9                        root stylesheet
9:41:38 PM: DEPRECATION WARNING: Using / for division outside of calc() is deprecated and will be removed in Dart Sass 2.0.0.
9:41:38 PM: Recommendation: math.div($spacer, 2) or calc($spacer / 2)
9:41:38 PM: More info and automated migrator: https://sass-lang.com/d/slash-div
9:41:38 PM:     ╷
9:41:38 PM: 712 │ $nav-divider-margin-y:              $spacer / 2 !default;
9:41:38 PM:     │                                     ^^^^^^^^^^^
9:41:38 PM:     ╵
9:41:38 PM:     node_modules/bootstrap/scss/_variables.scss 712:37  @import
9:41:38 PM:     src/assets/scss/bootstrap/_bootstrap.scss 3:9       @import
9:41:38 PM:     src/assets/scss/app.scss 2:9                        root stylesheet
9:41:38 PM: DEPRECATION WARNING: Using / for division outside of calc() is deprecated and will be removed in Dart Sass 2.0.0.
9:41:38 PM: Recommendation: math.div($spacer, 2) or calc($spacer / 2)
9:41:38 PM: More info and automated migrator: https://sass-lang.com/d/slash-div
9:41:38 PM:     ╷
9:41:38 PM: 717 │ $navbar-padding-y:                  $spacer / 2 !default;
9:41:38 PM:     │                                     ^^^^^^^^^^^
9:41:38 PM:     ╵
9:41:38 PM:     node_modules/bootstrap/scss/_variables.scss 717:37  @import
9:41:38 PM:     src/assets/scss/bootstrap/_bootstrap.scss 3:9       @import
9:41:38 PM:     src/assets/scss/app.scss 2:9                        root stylesheet
9:41:41 PM: WARNING: 86 repetitive deprecation warnings omitted.
9:41:46 PM:  WARNING  Compiled with 3 warnings8:41:46 PM
9:41:46 PM:  warning 
9:41:46 PM: asset size limit: The following asset(s) exceed the recommended size limit (244 KiB).
9:41:46 PM: This can impact web performance.
9:41:46 PM: Assets:
9:41:46 PM:   css/app.f3984599.css (409 KiB)
9:41:46 PM:   js/chunk-vendors.3cb81b78.js (2.25 MiB)
9:41:46 PM:  warning 
9:41:46 PM: entrypoint size limit: The following entrypoint(s) combined asset size exceeds the recommended limit (244 KiB). This can impact web performance.
9:41:46 PM: Entrypoints:
9:41:46 PM:   app (2.8 MiB)
9:41:46 PM:       css/chunk-vendors.71a233fb.css
9:41:46 PM:       js/chunk-vendors.3cb81b78.js
9:41:46 PM:       css/app.f3984599.css
9:41:46 PM:       js/app.c7944fc0.js
9:41:46 PM:  warning 
9:41:46 PM: webpack performance recommendations:
9:41:46 PM: You can limit the size of your bundles by using import() or require.ensure to lazy load some parts of your application.
9:41:46 PM: For more info visit https://webpack.js.org/guides/code-splitting/
9:41:46 PM:   File                                   Size              Gzipped
9:41:46 PM:   dist/js/chunk-vendors.3cb81b78.js      2307.10 KiB       746.09 KiB
9:41:46 PM:   dist/js/app.c7944fc0.js                82.97 KiB         22.14 KiB
9:41:46 PM:   dist/css/app.f3984599.css              408.65 KiB        60.89 KiB
9:41:46 PM:   dist/css/chunk-vendors.71a233fb.css    70.05 KiB         5.13 KiB
9:41:46 PM:   Images and other types of assets omitted.
9:41:46 PM:  DONE  Build complete. The dist directory is ready to be deployed.
9:41:46 PM:  INFO  Check out deployment instructions at https://cli.vuejs.org/guide/deployment.html
9:41:47 PM: ​
9:41:47 PM: (build.command completed in 18.1s)
9:41:47 PM: ​
9:41:47 PM: ────────────────────────────────────────────────────────────────
9:41:47 PM:   2. Functions bundling                                         
9:41:47 PM: ────────────────────────────────────────────────────────────────
9:41:47 PM: ​
9:41:47 PM: Packaging Functions from functions directory:
9:41:47 PM:  - auth_login.js
9:41:47 PM: ​
9:41:47 PM: ​
9:41:47 PM: (Functions bundling completed in 128ms)
9:41:47 PM: ​
9:41:47 PM: ────────────────────────────────────────────────────────────────
9:41:47 PM:   3. Deploy site                                                
9:41:47 PM: ────────────────────────────────────────────────────────────────
9:41:47 PM: ​
9:41:47 PM: Starting to deploy site from 'frontend/research/dist'
9:41:47 PM: Creating deploy tree 
9:41:47 PM: 0 new files to upload
9:41:47 PM: 1 new functions to upload
9:43:06 PM: Failed to upload file: auth_login
9:43:06 PM: Section completed: deploying
9:43:06 PM: Site deploy was successfully initiated
9:43:06 PM: ​
9:43:06 PM: (Deploy site completed in 1m 18.8s)
9:43:06 PM: ​
9:43:06 PM: ────────────────────────────────────────────────────────────────
9:43:06 PM:   Netlify Build Complete                                        
9:43:06 PM: ────────────────────────────────────────────────────────────────
9:43:06 PM: ​
9:43:06 PM: (Netlify Build completed in 1m 37.1s)
9:43:06 PM: Caching artifacts
9:43:06 PM: Started saving node modules
9:43:06 PM: Finished saving node modules
9:43:06 PM: Started saving build plugins
9:43:06 PM: Finished saving build plugins
9:43:06 PM: Started saving yarn cache
9:43:09 PM: Finished saving yarn cache
9:43:09 PM: Started saving pip cache
9:43:09 PM: Finished saving pip cache
9:43:09 PM: Started saving emacs cask dependencies
9:43:09 PM: Finished saving emacs cask dependencies
9:43:09 PM: Started saving maven dependencies
9:43:09 PM: Finished saving maven dependencies
9:43:09 PM: Started saving boot dependencies
9:43:09 PM: Finished saving boot dependencies
9:43:09 PM: Started saving rust rustup cache
9:43:09 PM: Finished saving rust rustup cache
9:43:09 PM: Started saving go dependencies
9:43:09 PM: Finished saving go dependencies
9:43:09 PM: Build script success
9:43:09 PM: Section completed: building
9:43:11 PM: Uploading Cache of size 703.2MB
9:43:16 PM: Section completed: cleanup
9:43:16 PM: Finished processing build request in 2m8.758411712s

I tried deleting the site from netlify and starting from scratch, it did not help.

Hey @papak69,

We’re investigating this in the helpdesk.

solved via support - issue with assigned region.