Netlify functions. Error: Cannot find module

I know this has been posted a lot on this forum, but I couldn’t find one that solved my case.
I am trying to build email functionalities to my web using node-mailjet. It uses Netlify’s serverless function to send emails.
Everything works fine when I run ntl dev locally. But when I uploaded the website to Netlify, I’m getting this error: "Error: Cannot find module 'node-mailjet'.
I looked around other topics already in the forum and followed some solutions, namely adding
[functions] external_node_modules = ["node-mailjet"] node_bundler = "esbuild"
to my netlify.toml file. I also tried installing v3 of node-mailjet instead of v6. But the problem persists.
I have "node-mailjet": "^3.3.7", listed as dependency in package.json.

Any help would be appreciated.

Hi @1214443427 , thanks for the post and welcome.
Kindly update your mailjet package to the latest version and then share a code snippet of how you are importing it in your code.
You might have done that already however I want to take another look at it in order to help with the debugging.