Netlify form submissions returning 400 'Bad request, missing form'

We are using Ajax / fetch, as documented here. Netlify is returning HTTP 400, with body ‘Bad request, missing form’ on every POST. And yet I can find the form submissions in Netlify Forms UI.

Here’s an example submission.

Method: POST

User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/ Safari/537.36
Content-Type: application/x-www-form-urlencoded



As of 3 hours ago, that form seems to have received a submission. Has something changed here?

That’s what I meant by ‘and yet I can find the form submissions in Netlify UI’. The form registers submissions, but Netlify returns error 400.

You can easily reproduce this by submitting a POST request with the details I provided.

Where is the form on your website? I tried checking the pages in navigation and could not find it.

That specific form is only accessible by authenticated users. You’d need to sign up for free, log in and then go to

But I was able to reproduce this in other forms as well. What I would like to understand is why that POST request with the body and headers I included in my original post is returning error 400. Have you tried reproducing this?

Looks like the 400 is coming from your Edge Function(s). You have multiple Edge Functions running on that path and one of them is sending the 400.

Interesting! That’s very helpful, thanks. I’ll try and track this down.