Home
Support Forums

Netlify build suddenly ignoring NODE_VERSION (Failing)

Hi, it seems that NODE_VERSION env var has just stopped working today

Env vars
NODE_VERSION=14.15.0

Build Logs:

12:40:12 PM: Downloading and installing node v14.15.0...

12:40:12 PM: Downloading https://nodejs.org/dist/v14.15.0/node-v14.15.0-linux-x64.tar.xz...

12:40:12 PM: Computing checksum with sha256sum

12:40:12 PM: Checksums matched!

12:40:15 PM: Now using node v14.15.0 (npm v6.14.8)
12:13:09 PM: ────────────────────────────────────────────────────────────────
12:13:09 PM:   Netlify Build                                                 
12:13:09 PM: ────────────────────────────────────────────────────────────────
12:13:09 PM: ​
12:13:09 PM: ❯ Version
12:13:09 PM:   @netlify/build 12.12.0 <---------- No bueno 👈 🤷‍♂️🚫

Build error (Failing plugin which requires node >= 14)
The Node.js version is 12.16.3 but the plugin "/packages/netlify-xyz-cache" requires >= 14

I have tried changing the build image from Ubuntu Xenial 16.04 (default) to Ubuntu Focal 20.04 (beta) without any luck.

first failed deployId: 60da1f27afe5da0007dde984
last failed deployId: 60da2595ac93d20007c08441

Last succesfull build: 60d756441989be0008ea75d1

The problem started today, we didn’t change any env vars.

Thanks!

Hey there,

Try creating a .nvmrc file in your projects root and put the Node version wanted inside (for your instance v14)
not too sure if you need the v or not so if it doesn’t work at first then try removing it

Hope this helps :slightly_smiling_face:

Kyle.

thanks for the suggestion @kylesloper.
I’ve ran node -v > .nvmrc

which generated .nvmrc with v14.16.0

pushed but the problem persists…

2:08:10 PM: Attempting node version 'v14.16.0' from .nvmrc

2:08:13 PM: Now using node v14.16.0 (npm v6.14.11)

2:09:39 PM:   Netlify Build                                                 
2:09:39 PM: ────────────────────────────────────────────────────────────────
2:09:39 PM: ​
2:09:39 PM: ❯ Version
2:09:39 PM:   @netlify/build 12.13.0
2:09:39 PM: 

Error
The Node.js version is 12.16.3 but the plugin "/packages/netlify-backpack-cache" requires >= 14

I have a feeling this is a problem with Netlify Build plugin / engine?

Anybody from netlify here? - This is pretty urgent thanks

Mmm that seems like a bit of a contradiction to me…

Now using node v14.16.0 (npm v6.14.11)

The Node.js version is 12.16.3

I’ll do some research to if this is an issue we have seen before.
In the mean time I’ll escalate this to a support engineer… they should be able to give you some suggestions tomorrow.

If you have a paid plan remember you can contact support directly since you do mention this issues urgency.

2 Likes

Thanks @kylesloper we are on an enterprise plan and Its now a problem not only on this site but in other sites that depend on v14.6

A support engineer will be on the case as soon as possible.

2 Likes

Hi all,
I believe this is due to our recent change to the Node version we use to run Build Plugins: Breaking change: Using system Node version to run Build Plugins I’ve gone ahead and disabled this feature for the sites in your account. Could you please trigger another build and see how it goes?

2 Likes

Hi @jen, thanks for the prompt response. This seems to have worked and our builds are working again.

I’ve just read the forum post you posted and I can’t help but think that this is some kind of internal regression on your feature set? Is node 12.2 going to be the only version supported? And if yes for how long? What was the rationale to not support 14 and others?

It seems to me that a breaking change, such as this, should be communicated to enterprise clients ahead of time, so that we can opt-in/out and more importantly provide support and fixes so that our clients do not experience a service downtime.

JP

100%. This was an oversight on our end. In our planning and communications around this breaking change, we were imagining the migration path being from plugins on Node 8.x and 10.x up to Node 12- not downgrading users on Node 14+ down to 12. The feature is currently rolled out behind a feature flag and, given the impact we’re seeing, we’re working on a new comms plan. Sorry you got caught in the initial rollout.

3 Likes

Ok thanks for the clarification @jen . Is there a deadline when this “feature flag” opt/out will stop working for us?

Hey @jpprietobaez, we won’t remove the opt-out flag without more discussion with you. If we move forward with this rollout, we will be directly in touch with enterprise customers about next steps. Does that work for you?

1 Like

Yes, thank you for getting back to us. Speak soon.

Hey @jpprietobaez,
I wanted to share an update on this:

Please let me know if you have any questions or concerns!

1 Like