My 3 rewrites are not working as I intend, no page displays

I have four webpages in question here on Netlify. One is a Portfolio which links to three projects (currently), and then those three projects.

Portfolio is

Projects are -

When visitors to my portfolio page click on a project, I want the project to load while the URL displays in this format -,, etc.

I’ve troubleshooted using the AI Chat Bot, Netlify documentation, searched through the Forum, checked my deploy logs (my three redirect rules have been processed as shown in the screenshot), and even cleared the production-deploy cache and rebuilt…I seem to have my file syntax correct (have tried old/new and to/from in both orders) and I’m using absolute links instead of relative links in my portfolio and file placed correctly, but it isn’t behaving as I intend/expect.

The screenshot shows my _redirects file and my netlify.toml file. I’ve used both and the projects aren’t loading when I click the link set to redirect (as a rewrite). I’m having these same results using Chrome, Firefox, and Edge.

I’ve copy/pasted the source urls (… to check and they are correct and working.

Any help would be greatly appreciated.

Your issue isn’t the proxy, that’s clearly working.
The issue is the file references, and you’ll need to add other redirects or to use absolute urls.

To break down what’s occuring, looking at just the first example:

The entire source of the page is:

<script src="" crossorigin="anonymous"></script><!doctype html><html lang="en"><head><meta charset="utf-8"/><script defer="defer" src="/static/js/main.6dbcc4ee.js"></script><link href="/static/css/main.43045ee7.css" rel="stylesheet"></head><body><noscript>You need to enable JavaScript to run this app.</noscript><div id="root"></div></body></html>

There are references to:


When loading the site directly those resolve to:

When loading the site via the proxy you see:

They’re trying to load from:

As per your _redirects screenshot there is no rule that accounts for anything accessing /static/*:

So you’ll either need to add additional redirects to ensure those file requests are routed to the correct location, or adjust the output of the build of the “sub sites” to use absolute URLs to access their resources.

Thank you so very much, Nathan. It’s working perfectly now.

I greatly appreciate the thorough explanation with screenshots.

(I opted to add a few lines to the netlify.toml file, redirecting the scripts that were relative references.)


Glad to hear your got your rewrites up and running again. Great work and shoutout to Nathan for being so helpful in our community.