Jekyll builds consistently failing with `Error: superclass must be a Class (Faraday::DeprecatedConstant given)`

Hi, my builds on Jekyll have been working fine up till today. I have 26 sites on Netlify and none of them can build, with all of them returning the same error: “jekyll 3.8.5 | Error: superclass must be a Class (Faraday::DeprecatedConstant given)”

Is anyone experiencing this problem? My suspicion is that Netlify has changed their Jekyll setup/dependencies which is causing the builds to fail.

1 Like

faced the same issue today :frowning:

Mine was working fine too, and now I receive the same error, only i’m working with 3.8.6. I get the next error:

jekyll 3.8.6 | Error: superclass must be a Class (Faraday::DeprecatedConstant given).

If anyone finds a solution please do let me know.

Hi, so I managed to fix the problem. You can specify the version of the Ruby gems you want to use in a gemfile.lock. This will override whatever dev settings and versions are being used on netlify’s servers

Can you provide a example, of what you changed to solve the problem?

  • /Gemfile and /Gemfile.lock are required to list dependencies (e.g. “jekyll” or “middleman”) which your build needs. You can use bundle install to create Gemfile.lock from a Gemfile, whose contents must follow this specification.

As seen in these docs.

I believe the problem is caused by the faraday gem which was updated yesterday:

I downgraded my version of faraday to 0.15.3 by running
gem uninstall faraday
gem install faraday --version 0.15.3
and this allowed me to run Jekyll again.

1 Like