Issues with building pull request deploy previews

Hi @Scott, We have tried this a bunch of times and are unfortunately not able to consistently get branch PRs to build with netlify on any of our repos. This also applies to other sites we have as well and sadly is still not resolved.

The problem is not just that the reporting of the status is failing but that the deploy preview is not built at all. How can we resolve this?

Hey @ejfasf,
Looks like several of your sites are running on the older build image trusty instead of xenial. Here’s a list:

  • centrifuge-documentation
  • develop-centrifuge-docs
  • centrifuge-axis
  • centrifuge-axis-staging
  • staging-centrifuge-website
  • centrifuge-website

We’d recommend switching to xenial- The process for doing so, as well as more information about the differences between the build images, is outlined in this support guide:

Please let us know if this fixes things for you and if we can help with anything along the way.

Hi @jen,

We have updated the centrifuge-website project to use xenial after your message but this has not resolved our issue. The site is telling us that we should install the Github app and we’ve done this several times already (in this thread your team asked us to do it three times already).

This issue has persisted for months already without any resolution in sight.

What can we do to fix this?

Hi, @ejfasf. I can see when this repository and site were linked. This repo was linked on Mon, 07 Jan 2019 13:46:58 UTC +00:00. Seeing as that is four months prior to this topic being created, my best guess is that this site does need to have the repository relinked to resolve this.

When this site was linked on 2019-01-07, the GitHub app was not detected by the GitHub user that linked the site and repo at Netlify. I say “GitHub user” because our web app requires you to login to GitHub so we can make the API call to get the GitHub Netlify app installation id number.

Would you please test relinking this site and repo again now that we are sure the GitHub app is installed?

The relinking instructions can be found here, quoting:

To change which repository is linked to your site, go to Site settings > Build & deploy > Continuous deployment > Build settings , select Edit settings , then Link to a different repository .

Just select the same repository as the final step to “relink” the existing repository. If this doesn’t resolve the issue, please let us know.

We’re still having issues with the PR not being reported properly. The odd thing that in this instance some checks were successful while others were not.

Hi, @ejfasf. I’ve been trying to debug this. The repo itself is public and I can see the issue on specific PRs (for example PR #279 shows this currently when I check).

However, I see no hook failures which would be the most common root cause. Again, no hook failures are reported though. So, I’m asking the rest of the support team if they have any insight to why this is happening. (If no one else does, I’ll escalate this.)

We will have another update here as soon as we know more.

Hey @ejfasf ,

Based on this response, could you browse here in your UI and select “One notification per repo”?