Issues with building pull request deploy previews

You’ve linked us to a medium post rather than a commit - mind updating your details?

It could certainly be a bug, but that would be surprising, since you are one of hundreds of thousands using this workflow and nobody else has seen anything, so we’ll keep debugging and see where it leads us :slight_smile:

oops, I fixed the link.

We merged something into master today which did not trigger a build either:

github - com centrifuge/website/commit/09ad524d561a10a0fe2df134e206c0600247588f

(For some reason discourse is not accepting github as a link)

It seems like you’re not getting webhooks reliably from github?

Your assertion that we aren’t getting hooks reliably feels unlikely to me, or we would have heard about it further, so let’s keep debugging :slight_smile:

We can’t see anything about what GitHub sends, but you can! Since you don’t use our github app on that website (perhaps this is actually the accident? Someone unhooked our GitHub app at your org in the GitHub admin settings?), could you tell us what you see on the configuration at GitHub under Settings->Hooks looks like? If you don’t have a webhook pointing to then you aren’t even trying to notify us with your current setup, so no bug, just misconfiguration…

It does not show up under Hooks but it does show up in the installed apps section:

Great start! Could you please as I asked hit the “configure” button and screenshot THAT for us?

Here you go:

Hey @ejfasf,

Just so we can be sure that you’re up-and-going again, have you tried reconnecting the repo to the App? This, 9/10, will solve the issue.

Yes, I have done that multiple times most recently after I filed the original issue. It did not resolve it.

I’m still not seeing PRs previews being built. Github is showing pending checks but nothing is happening.

By any chance do you have protected branches enabled in GitHub?

This might be inhibiting the checks.

@Scott we use protected branches but we have been doing that for a long time. I don’t think this is related. The setup did not change in the last year and it only recently stopped working.

How can we get netlify to start building our PRs again?

Hey @ejasf,

I’ve checked to see whether we have associated a repo with your site, This is returning null – reconnecting your repo with App has failed. Can you give this another try for me, please?

Hi @Scott, We have tried this a bunch of times and are unfortunately not able to consistently get branch PRs to build with netlify on any of our repos. This also applies to other sites we have as well and sadly is still not resolved.

The problem is not just that the reporting of the status is failing but that the deploy preview is not built at all. How can we resolve this?

Hey @ejfasf,
Looks like several of your sites are running on the older build image trusty instead of xenial. Here’s a list:

  • centrifuge-documentation
  • develop-centrifuge-docs
  • centrifuge-axis
  • centrifuge-axis-staging
  • staging-centrifuge-website
  • centrifuge-website

We’d recommend switching to xenial- The process for doing so, as well as more information about the differences between the build images, is outlined in this support guide:

Please let us know if this fixes things for you and if we can help with anything along the way.

Hi @jen,

We have updated the centrifuge-website project to use xenial after your message but this has not resolved our issue. The site is telling us that we should install the Github app and we’ve done this several times already (in this thread your team asked us to do it three times already).

This issue has persisted for months already without any resolution in sight.

What can we do to fix this?

Hi, @ejfasf. I can see when this repository and site were linked. This repo was linked on Mon, 07 Jan 2019 13:46:58 UTC +00:00. Seeing as that is four months prior to this topic being created, my best guess is that this site does need to have the repository relinked to resolve this.

When this site was linked on 2019-01-07, the GitHub app was not detected by the GitHub user that linked the site and repo at Netlify. I say “GitHub user” because our web app requires you to login to GitHub so we can make the API call to get the GitHub Netlify app installation id number.

Would you please test relinking this site and repo again now that we are sure the GitHub app is installed?

The relinking instructions can be found here, quoting:

To change which repository is linked to your site, go to Site settings > Build & deploy > Continuous deployment > Build settings , select Edit settings , then Link to a different repository .

Just select the same repository as the final step to “relink” the existing repository. If this doesn’t resolve the issue, please let us know.

We’re still having issues with the PR not being reported properly. The odd thing that in this instance some checks were successful while others were not.

Hi, @ejfasf. I’ve been trying to debug this. The repo itself is public and I can see the issue on specific PRs (for example PR #279 shows this currently when I check).

However, I see no hook failures which would be the most common root cause. Again, no hook failures are reported though. So, I’m asking the rest of the support team if they have any insight to why this is happening. (If no one else does, I’ll escalate this.)

We will have another update here as soon as we know more.

Hey @ejfasf ,

Based on this response, could you browse here in your UI and select “One notification per repo”?