Home
Support Forums

Issues with base build directory during deploys

All of a sudden my builds/deploys are not respecting the base build directory.

My deploy logs used to look like:
9:20:11 AM: Finished fetching cache in 875.520474ms
9:20:11 AM: Starting to prepare the repo for build
9:20:11 AM: Preparing Git Reference refs/heads/master
9:20:12 AM: No build command found, continuing to publishing
9:20:12 AM: Starting to deploy site from ‘demo’
9:20:12 AM: Creating deploy tree
9:20:12 AM: Creating deploy upload records

Now they look like:
8:40:35 AM: Preparing Git Reference refs/heads/master
8:40:36 AM: No build command found, continuing to publishing
8:40:36 AM: Starting to deploy site from ‘’
8:40:36 AM: Creating deploy tree
8:40:37 AM: Creating deploy upload records

Notice that it’s now not using the ‘demo’ directory. The deploy settings still show ‘demo’ as the base build directory and I haven’t actually changed anything.

I wonder if something changed recently or this is a known issue?

Thanks

Hey @dimxasnewfrozen,
That is definitely unintended and looks like a bug to me! I will get that filed internally. In the meantime, you can try one of these two options:

  1. In your build dashboard here https://app.netlify.com/sites/abcemergencyresponse/settings/deploys#build-settings, click “Edit settings” and add / to the Publish directory.

    It will look strange, like this:

    But it should get your deploys working.

  2. The other option is to add a netlify.toml file in your repository’s root directory that looks like this:

    # netlify.toml
    [build]
       base = "demo/"
       publish = "/"   
    

Let us know if that helps and we will definitely update this thread as we learn more about that bug!

We fixed this! You can read more about the change over here → Breaking change: Fixing the default publish directory in monorepo configurations