Issues when deploying @nuxtjs/gtm and @nuxtjs/google-analytics

Hi all,

Have run across a weird issue where when deploying to netlify using nuxt generate and trying to use packages @nuxtjs/gtm and @nuxtjs/google-analytics to inject GA and GTM.

When running nuxt generate and nuxt start locally, GA and GTM show up in WAPPALYZER, but when deploying to netlify with using the same nuxt generate command. GA and GTM don’t show up in WAPPALYZER.

I’ve inspected the page source and both pages have the same gtm code.

Very weird? Just wondering if anyone’s had this issue deploying to netlify?

You can inspect our deployment at

Very weird

Hey @nikolajfrey,

If your sites have the same code and if the code appears to be working fine, do you really need to worry about WAPPALYZER?

It’s not just WAPPALYZER, the tracking code doesn’t actually work when publishing, it’s really weird because it works when I build locally using nuxt generate, but deploying with nuxt generate the tracking code doesn’t work, very very weird.

The only thing I can think of is that it’s a domain issue but generally google tracking works on any domain, there’s no whitelist system.

I’ve also tried clearing network caches several times…

Hey @nikolajfrey,

As far as I can see, the script exists in the rendered page:

Has something changed or is it still not working?