Internal error during "Edge Functions bundling"

I am having this issue. Pretty sure is something internal because I am following Netlify webapp steps. Weird thing is I have a older site with almost same content and deployed well.

Is a Nextjs App. I will really apprecciate if you can help me.

11:39:05 AM:   5. Edge Functions bundling                                    
11:39:05 AM: ────────────────────────────────────────────────────────────────
11:39:05 AM: ​
11:39:05 AM: Packaging Edge Functions from .netlify/edge-functions directory:
11:39:05 AM:  - rsc-data
11:39:06 AM: Could not load edge function at '/opt/build/repo/.netlify/edge-functions/rsc-data/rsc-data.ts'
11:39:06 AM: TypeError: Cannot read properties of null (reading 'endsWith')
11:39:06 AM:     at file:///opt/build/repo/.netlify/edge-functions/edge-shared/rsc-data.ts:38:48
11:39:06 AM:     at Array.filter (<anonymous>)
11:39:06 AM:     at getRscDataRouter (file:///opt/build/repo/.netlify/edge-functions/edge-shared/rsc-data.ts:38:8)
11:39:06 AM:     at file:///opt/build/repo/.netlify/edge-functions/rsc-data/rsc-data.ts:4:17
11:39:06 AM: ​
11:39:06 AM:   Internal error during "Edge Functions bundling"               
11:39:06 AM: ────────────────────────────────────────────────────────────────
11:39:06 AM: ​
11:39:06 AM:   Error message
11:39:06 AM:   TypeError: Expected a string
11:39:06 AM: ​
11:39:06 AM:   Error location
11:39:06 AM:   During Edge Functions bundling
11:39:06 AM:       at module.exports (/opt/buildhome/node-deps/node_modules/@netlify/edge-bundler/node_modules/glob-to-regexp/index.js:3:11)
11:39:06 AM:       at pathToRegularExpression (file:///opt/buildhome/node-deps/node_modules/@netlify/edge-bundler/dist/node/manifest.js:73:31)
11:39:06 AM:       at getRegularExpression (file:///opt/buildhome/node-deps/node_modules/@netlify/edge-bundler/dist/node/manifest.js:94:12)
11:39:06 AM:       at file:///opt/buildhome/node-deps/node_modules/@netlify/edge-bundler/dist/node/manifest.js:37:25
11:39:06 AM:       at Array.forEach (<anonymous>)
11:39:06 AM:       at generateManifest (file:///opt/buildhome/node-deps/node_modules/@netlify/edge-bundler/dist/node/manifest.js:32:18)
11:39:06 AM:       at writeManifest (file:///opt/buildhome/node-deps/node_modules/@netlify/edge-bundler/dist/node/manifest.js:115:22)
11:39:06 AM:       at bundle (file:///opt/buildhome/node-deps/node_modules/@netlify/edge-bundler/dist/node/bundler.js:73:28)
11:39:06 AM:       at runMicrotasks (<anonymous>)
11:39:06 AM:       at processTicksAndRejections (node:internal/process/task_queues:96:5)

Hi @javiercornejo,

It seems to be related to this: Bug: `appDir` applications can have `dataRoute: null` · Issue #1940 · netlify/next-runtime · GitHub

Thanks. No it wasn’t that (or maybe is related but directly) I solved it by removing a folder (.page) I don’t think is this and downgrading some libs (bellow) Not sure which one is conflicting or failing in Netlify but tomorrow I will know.

    "@plasmicapp/react-web": "^0.2.166",	    "@plasmicapp/react-web": "^0.2.157",
    "@plasmicpkgs/plasmic-basic-components": "^0.0.119",	    "@plasmicpkgs/plasmic-basic-components": "^0.0.114",
    "encoding": "^0.1.13",
    "next": "13.2.4",	    "next": "13.1.6",

Thanks for the update @javiercornejo

can we have more insight? did you manage to deploy? what ‘.page’ folder? I personally haven’t started to code but I cannot deploy…I just added tailwindcss and chakra ui

Can you suggest any solutions to resolve this issue? I’m encountering the same error while attempting to deploy the project. Additionally, I have an experimental app folder but I’m uncertain if it’s related to the error.

Have you updated all your deps. I can’t see why this would be internal :confused:

Did u manage to solve this? I am getting the exact same error with my next deployment. All of my deps are at latest and i even tried canary.

Edit: installing the @netlify/plugin-nextjs package into my project solved the issue for me

Unfortunately no, I am having same issue now I did nothing, it seems to be random within some deploys. My stack is nextjs and is conflicting with edge function which I am not using btw.

Ok thanks I am going to try it

I can confirm that solved the problem to me also. thanks mate.
I swear never saw that package in the doc.

1 Like

Thanks for coming back and confirming you found your solution.

@SamO Looks like this issue is happening again. I made a new thread about it here: Next App Edge Function Bundling Error

installing the plugin no longer solves the issue