Installing @netlify/plugin-nextjs@4.3.0 hangs on site setup

Version 4.3.0 of the NextJS Plugin is not installing. I set up a site two weeks ago with 4.2.7 and it all worked perfectly. However, now 4.3.0 fails.

I have tried this on a few different new sites in different orgs on Netlify, with the same repo.

I am having the same issue.

Hey folks :wave:

Thanks so much for reaching out and letting us know. Can you please share your netlify site name and your project repos? If your project repos are private, could you share a reproduction? I have updated the team that works on the plugin and we are investigating.

In the interim, downgrading to 4.2.7 should keep your builds working.

Same issue here, adding "@netlify/plugin-nextjs": "4.2.7" as a dev dependency fixed it for me for now.

I was trying to deploy fresh from the nextjs blog template: GitHub - netlify-templates/nextjs-blog-theme: A customizable Next.js and Tailwind blog starter. Designed by the Bejamas agency.

Does it still happen with 4.3.0 as a dev dependency (rather than auto-installed)?

1 Like

4.3.0 worked just now, Iā€™ll try with 4.3.1 and see as well.

1 Like

Huh! 4.3.1 worked fine as a dev dependency.

1 Like

Thank you so much for coming back and letting us know! Glad that this is working for you now. Please feel free to follow up with any additional questions.

1 Like

This also works for me now after adding it as a dependency

1 Like