How to make my domain to point to Netlify

Netlify site name: subtle-moxie-3b12a0

DNS issues: My records do not appear to point to Netlify.

Squarespace: Custom record
add record
Host Netlify
CName provided

It’s been five days and still not working. Please help. Thanks.

The better the post - the faster the answer.

Your domain indeed doesn’t seem to be served by Netlify. None of these are Netlify records:

dig A +short husnamemon.net
198.185.159.145
198.49.23.144
198.49.23.145
198.185.159.144


dig CNAME +short www.husnamemon.net
ext-sq.squarespace.com.

Thank you for your message. What do you suggest I should do?

Have you already checked the docs: Configure external DNS for a custom domain | Netlify Docs?

Yes, I followed these steps to add Netlify as a custom record to Squarespace domain settings. Do I need make it default? Thanks.

I haven’t used Squarespace and I don’t know how to configure the DNS there. You can ask their support for help. Share the above link with them and ask how to configure the required records.

Thank you for your reply. I checked with Squarespace and it is now pointing to Netlify. It has been two days and I am still getting the same error message on the Netlify website that it doesn’t appear to be served by Netlify. What should I do now?

@FinStudent2021 if you’re intending to use external DNS, your nameservers shouldn’t be pointing at

dns1.p09.nsone.net.
dns2.p09.nsone.net.
dns3.p09.nsone.net.
dns4.p09.nsone.net.

Also, you should have an A record for husnamemon.net pointing at 75.2.60.5

I am sorry but I am not familiar with these settings. The error message said that it should point to Netlify.

I will go back to the Squarespace domain and add another custom record

A record
75.2.60.5

What should be the host name? Please see the screenshot of the existing settings. Can you please break down the steps I need to do to get this working? Many thanks.

@FinStudent2021 this guide gives you detailed instructions on setting up your records:

For your A and CNAME you can follow these instructions:

Type Name Value
A @ 75.2.60.5
CNAME www subtle-moxie-3b12a0.netlify.app

Thank you! I have done it. What should be the next step? Wait for 24-48 hours and try again.

Hi @FinStudent2021,

Yes, after making the change you may have to wait for up to 24 - 48 hours for propagation. However, checking the domain now, I do see that DNS is configured properly and that the domain resolves.

Thank you very much!

You’re welcome. Have a great day!