How to disable "Uppercase URLs are redirected to Lowercase URLs" feature?

  • Hexo Site:

  • Problem URL:!/

Google Search Console notified me that this URL has index problems (Failed: Redirect Error) (Page Indexing report - Search Console Help).

The URL I specified in sitemap is!/ ,which has uppercase characters. Netlify will automatically rewrite/redirect!/ to!/ . However, the redirect won’t happen when I deployed my Hexo site to OSS+CDN (for example Backblaze B2 + Cloudflare) and I prefer the latter.

I didn’t enable Asset Optimization/Pretty URLs or netlify.toml. Please tell me how to solve it. Thanks a lot!

Hi @Pil0tXia,

Thanks for reaching out!

I found this Netlify forum post on a similar issue:

Let us know if you have any questions.

No, I didn’t set any netlify.toml file. I want to disable any redirect and keep my URLs with uppercase. May you please tell me how to do it?

Netlify automatically normalises URLs to lowercase and there’s no way to disable it.

Is there anything I can do?

I don’t believe so, sorry.