Home
Support Forums

How to add a Subdomain in Netlify

Hi ,

Hope you are well.

I have a domain ariops-dev.netlify.app

This points to ariops.org.uk

I also have a subdomain community.ariops.org.uk I want to point the subdomain at the IP address of the sever hosting the Discourse forum

How do I add an A record in Netlify for community

I have a free account and I can’t find a way to create an A record in DNS Settings

Namecheap is the register of the domain ariops.org.uk

The Netlify name servers are configured successfully

Any ideas?

There’s an option to set an A record in DNS (it’s even selected as default when you open DNS settings).

It would be available here: https://app.netlify.com/teams/<team name>/dns/<domain name>. Just click on Add new record and fill in the details as required.

@hrishikesh

Thanks I found it now I have a different problem it looks as if a record already exists and it says it is a default record and can’t be change the value should be the IP but it is the default netlify app name any suggestions?

You need to add the name of the subdomain in the host name field. For example, if you want forum.domain.com, add host name as forum.

EDIT: My bad, didn’t check you screenshot properly.

So, I just checked, I was able to add a subdomain record without any issue.I just clicked on add a new record, filled in the details and it works. From your screenshot, it looks like you’ve connected the domain community… also to Netlify.

Hi, @Cyber-Bunker. This is an issue I see all the time. This is a “conflicting NETLIFY type DNS record” issue:

The three key points in the support guide are summarized as:

  • These records are locked by default and can be unlocked by our support team.
  • These records only connect domain names to IP addresses.
  • These records do not control which site the domain name is linked to (if any).

I’ve unlocked the existing records for the domain you mentioned now. If you delete any NETLIFY/NETLIFYv6 type records for community.ariops.org.uk the A records (or CNAME records) will start working.

If there are other questions or concerns, please let us know.

Hi @luke

Thank you so much for this I was able to delete the existing records and create an A record and point it at the IP I have.

After a few minutes this worked.