How to activate Admob app-ads.txt with Git deployment?

Hello, my site is is a static website connected to GitHub for easier deployment. Yesterday I’ve deployed it and added the custom domain and also the https certificate.

The thing is that we do mobile gaming, and we have ads, for the ads to work correctly we need to have a app-ads.txt on the root of the project, which I added to the Github repo but it seems like admob is not detecting it and if I try to access by it dosnt open the file.

We can see here how the file is on the repo and it got deployed, but admob is not validating it yet, what I’m missing?

Hello @tihomir22,
Based on your image I see that you named the file ads.txt instead of app-ads.txt. Kindly rename it to app-ads.txt to see if it works.

It can take up to 24 hours for AdMob to crawl and verify your app-ads.txt files. Wait at least 24 hours for the app-ads.txt status to update.

If you’ve recently added a developer website or updated your app listing in Google Play, allow up to 24 hours for AdMob to detect these changes.

Also note that based on the Google AdMob help documentation it’s stated that it takes 24 hours for AdMob to crawl the app-adds.txt on your site.

However if it’s past 24 hours and the problem still persists, kindly visit the Google AdMob help documentation using the link below and then make sure you follow the steps on how to properly add the app-ads.txt files.

Hope this helps.

1 Like

Thanks, I didn’t notice that file name itself was wrong, checked everything else, but not the basic :smiley: :smiley:

Kind regards


@tihomir22 I am glad I was able to help. If your problem was solved based on the stated solution above, kindly mark it as solved in order to help others in the future who might also experience a similar problem.


1 Like