Help me (newbie)

PLEASE help us help you by writing a good post!

  • we need to know your netlify site name. Example: gifted-antelope-58b104.netlify.app
  • DNS issues? Tell us the custom domain, tell us the error message! We can’t help if we don’t know your domain.
  • Build problems? Link or paste the FULL build log & build settings screenshot

The better the post - the faster the answer.
10:20:41 AM: Build ready to start
10:20:44 AM: build-image version: 122b31996ccaffd45d820a452d6227f8312110cc (focal)
10:20:44 AM: build-image tag: v4.5.3
10:20:44 AM: buildbot version: 44e4d661fad7f5ef0b9bffed6dfdedaa2c1ad008
10:20:44 AM: Fetching cached dependencies
10:20:45 AM: Failed to fetch cache, continuing with build
10:20:45 AM: Starting to prepare the repo for build
10:20:45 AM: No cached dependencies found. Cloning fresh repo
10:20:45 AM: git clone GitHub - saamnguyen/travel-proj
10:20:45 AM: Preparing Git Reference refs/heads/main
10:20:46 AM: Parsing package.json dependencies
10:20:47 AM: Starting build script
10:20:47 AM: Installing dependencies
10:20:47 AM: Python version set to 2.7
10:20:47 AM: v16.13.2 is already installed.
10:20:48 AM: Now using node v16.13.2 (npm v8.1.2)
10:20:48 AM: Started restoring cached build plugins
10:20:48 AM: Finished restoring cached build plugins
10:20:48 AM: Attempting ruby version 2.7.2, read from environment
10:20:50 AM: Using ruby version 2.7.2
10:20:50 AM: Using PHP version 8.0
10:20:50 AM: Started restoring cached yarn cache
10:20:50 AM: Finished restoring cached yarn cache
10:20:51 AM: No yarn workspaces detected
10:20:51 AM: Started restoring cached node modules
10:20:51 AM: Finished restoring cached node modules
10:20:51 AM: Installing NPM modules using Yarn version 1.22.10
10:20:52 AM: yarn install v1.22.10
10:20:52 AM: warning package-lock.json found. Your project contains lock files generated by tools other than Yarn. It is advised not to mix package managers in order to avoid resolution inconsistencies caused by unsynchronized lock files. To clear this warning, remove package-lock.json.
10:20:52 AM: [1/4] Resolving packages…
10:20:52 AM: warning @material-ui/core@4.12.3: You can now upgrade to @mui/material. See the guide: Migration from v4 to v5 - Material UI
10:20:55 AM: [2/4] Fetching packages…
10:22:22 AM: info fsevents@2.3.2: The platform “linux” is incompatible with this module.
10:22:22 AM: info “fsevents@2.3.2” is an optional dependency and failed compatibility check. Excluding it from installation.
10:22:22 AM: info fsevents@1.2.13: The platform “linux” is incompatible with this module.
10:22:22 AM: info “fsevents@1.2.13” is an optional dependency and failed compatibility check. Excluding it from installation.
10:22:22 AM: [3/4] Linking dependencies…
10:22:22 AM: warning " > @testing-library/user-event@12.8.3" has unmet peer dependency “@testing-library/dom@>=7.21.4”.
10:22:22 AM: warning “react-scripts > @typescript-eslint/eslint-plugin > tsutils@3.21.0” has unmet peer dependency “typescript@>=2.8.0 || >= 3.2.0-dev || >= 3.3.0-dev || >= 3.4.0-dev || >= 3.5.0-dev || >= 3.6.0-dev || >= 3.6.0-beta || >= 3.7.0-dev || >= 3.7.0-beta”.
10:22:46 AM: [4/4] Building fresh packages…
10:22:48 AM: success Saved lockfile.
10:22:48 AM: Done in 116.20s.
10:22:48 AM: NPM modules installed using Yarn
10:22:49 AM: Started restoring cached go cache
10:22:49 AM: Finished restoring cached go cache
10:22:49 AM: go version go1.16.5 linux/amd64
10:22:49 AM: go version go1.16.5 linux/amd64
10:22:49 AM: Installing missing commands
10:22:49 AM: Verify run directory
10:22:51 AM: ​
10:22:51 AM: ────────────────────────────────────────────────────────────────
10:22:51 AM: Netlify Build
10:22:51 AM: ────────────────────────────────────────────────────────────────
10:22:51 AM: ​
10:22:51 AM: ❯ Version
10:22:51 AM: @netlify/build 26.1.7
10:22:51 AM: ​
10:22:51 AM: ❯ Flags
10:22:51 AM: baseRelDir: true
10:22:51 AM: buildId: 61f20f8942e4742c6e6f5399
10:22:51 AM: deployId: 61f20f8942e4742c6e6f539b
10:22:51 AM: ​
10:22:51 AM: ❯ Current directory
10:22:51 AM: /opt/build/repo
10:22:51 AM: ​
10:22:51 AM: ❯ Config file
10:22:51 AM: No config file was defined: using default values.
10:22:51 AM: ​
10:22:51 AM: ❯ Context
10:22:51 AM: production
10:22:51 AM: ​
10:22:51 AM: ────────────────────────────────────────────────────────────────
10:22:51 AM: 1. Build command from Netlify app
10:22:51 AM: ────────────────────────────────────────────────────────────────
10:22:51 AM: ​
10:22:51 AM: $ CI= npm run build
10:22:51 AM: > google-map-app@0.1.0 build
10:22:51 AM: > CI= react-scripts build
10:22:53 AM: Creating an optimized production build…
10:22:55 AM: Browserslist: caniuse-lite is outdated. Please run:
10:22:55 AM: npx browserslist@latest --update-db
10:22:55 AM: Why you should do it regularly:
10:22:55 AM: GitHub - browserslist/browserslist: 🦔 Share target browsers between different front-end tools, like Autoprefixer, Stylelint and babel-preset-env
10:23:28 AM: Failed to compile.
10:23:28 AM:
10:23:28 AM: Failed to load parser ‘babel-eslint’ declared in ‘.eslintrc.js’: Cannot find module ‘babel-eslint’
10:23:28 AM: Require stack:
10:23:28 AM: - /opt/build/repo/.eslintrc.js
10:23:28 AM: ​
10:23:28 AM: ────────────────────────────────────────────────────────────────
10:23:28 AM: “build.command” failed
10:23:28 AM: ────────────────────────────────────────────────────────────────
10:23:28 AM: ​
10:23:28 AM: Error message
10:23:28 AM: Command failed with exit code 1: CI= npm run build
10:23:28 AM: ​
10:23:28 AM: Error location
10:23:28 AM: In Build command from Netlify app:
10:23:28 AM: CI= npm run build
10:23:28 AM: ​
10:23:28 AM: Resolved config
10:23:28 AM: build:
10:23:28 AM: command: CI= npm run build
10:23:28 AM: commandOrigin: ui
10:23:28 AM: environment:
10:23:28 AM: - CI
10:23:28 AM: publish: /opt/build/repo/build
10:23:28 AM: publishOrigin: ui
10:23:28 AM: Caching artifacts
10:23:28 AM: Started saving node modules
10:23:28 AM: Finished saving node modules
10:23:28 AM: Started saving build plugins
10:23:28 AM: Finished saving build plugins
10:23:28 AM: Started saving yarn cache
10:23:37 AM: Finished saving yarn cache
10:23:37 AM: Started saving pip cache
10:23:37 AM: Finished saving pip cache
10:23:37 AM: Started saving emacs cask dependencies
10:23:37 AM: Finished saving emacs cask dependencies
10:23:37 AM: Started saving maven dependencies
10:23:37 AM: Finished saving maven dependencies
10:23:37 AM: Started saving boot dependencies
10:23:37 AM: Finished saving boot dependencies
10:23:37 AM: Started saving rust rustup cache
10:23:37 AM: Finished saving rust rustup cache
10:23:37 AM: Started saving go dependencies
10:23:37 AM: Finished saving go dependencies
10:23:40 AM: Build failed due to a user error: Build script returned non-zero exit code: 2
10:23:40 AM: Creating deploy upload records
10:23:40 AM: Failing build: Failed to build site
10:23:40 AM: Failed during stage ‘building site’: Build script returned non-zero exit code: 2
10:23:40 AM: Finished processing build request in 2m55.784281064s

Hi @finn-01

What the above error message is saying is that in the .eslintrc.js is the line

parser: 'babel-eslint',

however babel-eslint is not listed is the package.json under dependencies or devDependencies.