Gyp ERR! stack Error: Could not find any Python installation to use

I host my personal blog built using GridsomeJS: The build is failing today that was working properly all these days. Please help!


Build Log

  // netlify.toml
  publish = "dist"
  command = "gridsome build"
// package.json
    "name": "",
    "private": true,
    "scripts": {
      "build": "gridsome build",
      "develop": "gridsome develop",
      "explore": "gridsome explore",
      "newpost": "node scripts/newPost.js"
    "dependencies": {
      "@fullhuman/postcss-purgecss": "^1.3.0",
      "@gridsome/plugin-google-analytics": "^0.1.0",
      "@gridsome/plugin-sitemap": "^0.4.0",
      "@gridsome/source-filesystem": "^0.6.2",
      "@gridsome/transformer-remark": "^0.6.4",
      "fs": "0.0.1-security",
      "gridsome": "^0.7.23",
      "gridsome-plugin-remark-shiki": "^0.6.0",
      "gridsome-plugin-rss": "^1.2.0",
      "medium-zoom": "^1.0.4",
      "vue-disqus": "^4.0.1",
      "vue-parallaxy": "^1.1.1"
    "devDependencies": {
      "moment": "^2.24.0",
      "postcss-import": "^12.0.1",
      "postcss-nested": "^4.2.1",
      "tailwindcss": "^1.1.3",
      "tailwindcss-transitions": "^2.1.0"

The site is building fine locally.

Hey @aslam

You are using an older build image (v3.13.0) but installing the latest version of Node.js (v16.14.2) and it is this I believe is the issue. Likely one or more of the packages you are using are not compatible with this version of Node.js.

Quite likely the easiest solution is to set the Node.js version to v14.19.1 (which is the latest v14 release). There are several ways to do this as outlined in the Manage Dependencies documentation, though you will need to use the same method currently used.

Alternatively you can upgrade all the packages to the latest version (this may cause other issues in your code though) so you can (hopefully) use the latest version of Node.js.

1 Like

Great! that was it. Thanks a lot!!

1 Like