Git Gateway error

Thanks for following up @scottserok and I’m glad it worked out.
I’ve seen similar issues where just disabling & enabling git-gateway will result in a 404 when trying to access it so it might be related (in that case it the issue is resolve just by waiting some time). We’re still investigating it with our backend team.

I am having a similar issue. My error is Git Gateway Error: [object Object] in a yellow box.
In Netlify I have tried reseting the Deploy Key in settings->Build & deploy

I have also tried Disable Git Gateway in settings->Identity

I have also cleared my cache, reloaded, as well as giving it time. Still no luck.

Any help is appreciated

I was using the static/admin/config.yml file automatically generated by the getting started buttons on netlifycms.org.

I am not sure why but this yaml file did not include repo under backend:

backend:
  name: github
  repo: your-username/your-repo-name

By adding that and making sure it exactly matched my username and repo name I was able to log in.

Same issue here after changing my github repo name. Sounds like other people’s issues have been resolved by just waiting.


Getting a 401 unauthorized response. Hopefully, this issue resolves itself within the next few minutes.

1 Like

Hi @whipplepoint, thank for sharing your config.yml. By setting the backend to GitHub you’re actually not using git-gateway anymore, which is one way to solve this issue.
@bloxy, since you changed your repo name you might need to disable/enable git-gateway from Netlify’s site settings or even re-link the repo under build settings.

1 Like

Removing all cookies and refreshing the page worked for me


Might not be the real solution, but it should at least give a valid error response instead of Git Gateway Error: [object Object]

2 Likes

I am having a similar issue here. I setup an account on Netlify using an email instead of a github account.

When setting up the site I pointed it to my github repo. Even though I used a different email than the one I use for github.

After I setup my config file like so:

backend:
  name: git-gateway
  repo: byebyers/clearingkarmas
  branch: master

And was able to turn on identity and set up git-gateway like so

When creating an access token I was able to log into my github account so I figured that it would work. Still I am getting the same error.

Git Gateway Error: Please ask your site administrator to reissue the Git Gateway token.

I have tried creating a new one several times, cleared cache, reset the browser, and reset my pc but no luck.

Does my netlify email have to match my github one in order for this to work or am I missing something here?

I’m having the same problems and I cannot find a solution for this

@nogueira @byebyers I’m not sure if both of you have tried this but it was able to fix my issue!

Try switching your branch in config.yml from master to main. I initially had mine set to master, but then I noticed that my “Deploy contexts” section on Netlify showed my production branch as main.

Changing my yml branch to main worked! I also regenerated the key after changing the branch.

4 Likes

Thank you so much it worked!

Thanks for the help @ansh

1 Like

Hey @ansh,
Thanks so much for sharing this solution!

1 Like

Of course! This forum has been super helpful to me so I’m glad to help where I can :slight_smile:

3 Likes

This worked for me :raised_hands: Thanks @ansh!!!

Thanks, @ansh. :hugs: I just fixed mine now with your help

thank you for saying so! Please come back again soon :slight_smile:

This was the fix for me <3

This happened to me too after renaming my repo. After multiple token reissues, cache deletion, refreshes etc the solution that worked was to unlink the repo from Netlify and then relink it.

2 Likes

i got the same [object object] error - removed all cookies and voila it works again

I had the same problem when migrating a site to another branch in another repo. After having linked the new repo, I needed to change also the branch attribute under cms in config/_default/params.yaml

1 Like

Thanks for coming back and letting us know, @aretor :netliconfetti: