Gatsby-source-git failing all of a sudden

Hi there,

I’ve been using the gatsby-source-git plugin for a while now without issue, but in all my deployments today the remote git address seems to be having trouble and is spitting out a git error. I even tried re-running a deployment that worked from 5 days ago (7/23) which is also failing. Did something change with the Netlify worker git installation that would be causing a failure like this?

Git repo being pulled from: GitHub - architect-team/architect-cli: Command line interface for running Architect services locally

Build logs:

4:42:55 PM: ────────────────────────────────────────────────────────────────
4:42:55 PM:   Netlify Build                                                 
4:42:55 PM: ────────────────────────────────────────────────────────────────
4:42:55 PM: ​
4:42:55 PM: ❯ Version
4:42:55 PM:   @netlify/build 17.2.0
4:42:55 PM: ​
4:42:55 PM: ❯ Flags
4:42:55 PM:   deployId: 6101c12ee1018d070d57b986
4:42:55 PM: ​
4:42:55 PM: ❯ Current directory
4:42:55 PM:   /opt/build/repo
4:42:55 PM: ​
4:42:55 PM: ❯ Config file
4:42:55 PM:   /opt/build/repo/netlify.toml
4:42:55 PM: ​
4:42:55 PM: ❯ Context
4:42:55 PM:   deploy-preview
4:42:56 PM: ​
4:42:56 PM: ❯ Loading plugins
4:42:56 PM:    - @netlify/plugin-gatsby@1.0.3 from netlify.toml
4:42:56 PM: ​
4:42:56 PM: ────────────────────────────────────────────────────────────────
4:42:56 PM:   1. onPreBuild command from @netlify/plugin-gatsby             
4:42:56 PM: ────────────────────────────────────────────────────────────────
4:42:56 PM: ​
4:43:00 PM: Found a Gatsby cache. We’re about to go FAST. ⚡️
4:43:00 PM: Add `gatsby-plugin-netlify` to `gatsby-config.js` if you would like to support Gatsby redirects. 🎉
4:43:00 PM: ​
4:43:00 PM: (@netlify/plugin-gatsby onPreBuild completed in 4.4s)
4:43:00 PM: ​
4:43:00 PM: ────────────────────────────────────────────────────────────────
4:43:00 PM:   2. build.command from netlify.toml                            
4:43:00 PM: ────────────────────────────────────────────────────────────────
4:43:00 PM: ​
4:43:00 PM: $ npm run build
4:43:01 PM: > @architect-io/www@1.0.0 build /opt/build/repo
4:43:01 PM: > gatsby build
4:43:05 PM: success open and validate gatsby-configs, load plugins - 1.633s
4:43:06 PM: success onPreInit - 0.063s
4:43:06 PM: success initialize cache - 0.012s
4:43:06 PM: success copy gatsby files - 0.093s
4:43:07 PM: success Compiling Gatsby Functions - 0.857s
4:43:07 PM: success onPreBootstrap - 0.872s
4:43:07 PM: success createSchemaCustomization - 0.172s
4:43:08 PM: error fatal: No remote configured to list refs from.
4:43:08 PM: 
4:43:08 PM: 
4:43:08 PM:   Error: fatal: No remote configured to list refs from.
4:43:08 PM:   
4:43:08 PM:   - promise.js:90 toError
4:43:08 PM:     [repo]/[simple-git]/promise.js:90:14
4:43:08 PM:   
4:43:08 PM:   - promise.js:61 
4:43:08 PM:     [repo]/[simple-git]/promise.js:61:36
4:43:08 PM:   
4:43:08 PM:   - git.js:725 Git.<anonymous>
4:43:08 PM:     [repo]/[simple-git]/src/git.js:725:18
4:43:08 PM:   
4:43:08 PM:   - git.js:1475
4:43:08 PM:     [repo]/[simple-git]/src/git.js:1475:18
4:43:08 PM:   
4:43:08 PM:   - git.js:1433 fail
4:43:08 PM:     [repo]/[simple-git]/src/git.js:1433:20
4:43:08 PM:   
4:43:08 PM:   - git.js:1442 
4:43:08 PM:     [repo]/[simple-git]/src/git.js:1442:16
4:43:08 PM:   
4:43:08 PM:   - task_queues.js:95 processTicksAndRejections
4:43:08 PM:     internal/process/task_queues.js:95:5
4:43:08 PM:   
4:43:08 PM: 
4:43:08 PM: success Checking for changed pages - 0.001s
4:43:08 PM: success source and transform nodes - 1.422s
4:43:11 PM: success building schema - 2.402s
4:43:11 PM: warning The enum value "MdxFieldsEnum.fields___order" is deprecated. Sorting on fields that need arguments to resolve is deprecated.
4:43:11 PM: error There was an error in your GraphQL query:
4:43:11 PM: Cannot query field "symlinks" on type "MdxFrontmatter".
4:43:11 PM: If you don't expect "symlinks" to exist on the type "MdxFrontmatter" it is most likely a typo.
However, if you expect "symlinks" to exist there are a couple of solutions to common problems:
4:43:11 PM: - If you added a new data source and/or changed something inside gatsby-node.js/gatsby-config.js, please try a restart of your development server
4:43:11 PM: - The field might be accessible in another subfield, please try your query in GraphiQL and use the GraphiQL explorer to see which fields you can query and what shape they have
4:43:11 PM: - You want to optionally use your field "symlinks" and right now it is not used anywhere. Therefore Gatsby can't infer the type and add it to the GraphQL schema. A quick fix is to add at least one entry with that field ("dummy content")
4:43:11 PM: It is recommended to explicitly type your GraphQL schema if you want to use optional fields. This way you don't have to add the mentioned "dummy content". Visit our docs to learn how you can define the schema for "MdxFrontmatter":
4:43:11 PM: not finished createPages - 0.393s

Thanks in advance,

Hi @davidthor,

Is the behaviour same if you clear cache and deploy?

Well now I feel stupid – that solved the problem. Thanks for the help!

@hrishikesh I’m experiencing the same issue here. While clearing the cache and redeploying did work, subsequent builds failed with the same error. This seems to be caused by @netlify/plugin-gatsby as the problem doesn’t happen when I uninstall the plugin. This is unfortunate as I was hoping to take advantage of this plugin to speed up my Gatsby build times and use the incremental builds feature.

Hi @trevorblades,

Unfortunately, caching doesn’t work for all. That’s one of the downsides. As far as i remember, in the previous versions of Gatsby that I used (Gatsby 2), clearing its cache was often recommended to fix some issues. Not sure if it’s still relevant.

You could try to open an issue on the plugin’s repo to see if the developers have any better solution for you. If not, you’d have to continue without the plugin unfortunately.