Functions files upload constantly failing

I need advice to debug deploy
for my jsCHAT (ReactJS, Netlify Lambda, MongoDB chat app)
Everything is going good, but deployment fails when it comes to uploading files - it hangs for few minutes and then shows me message "failed to upload file: " with every function file. I tried also to re-deploy my old code, but also unsuccessfully. Tried on Xenial and Trusty images.

Hi @PetrusTryb, I’m still investigating what caused those failed deploys. I do see that newer deploys seem to be completing now. In any case, I’ll update here when I have more details on what happened.

Have you made any changes to your functions around Wednesday? It looks like your deploys started succeeding after then.

I have disconnected and connected back my GitHub account.
That fixed these deploy issues (but idk why).
I changed many things with this functions, but only GitHub account reconnection have fixed this problem.

Unfortunately, I don’t have an answer for you but I’m glad you resolved the issue by re-linking your github account. Let us know if it happens again and we’ll see if we can narrow down the cause.