Form messages are all there but the message content has all dissappeared

My site has a netlify contact form
This has worked for many months and I saw the messages it recieved with what users submitted
I recently logged on to see all the forms messages still there (with the date and the IP etc) but the message content is all gone, and when I download the CSV there is no message content column

Hi @00ffbb , thanks for the post and welcome.
First of all have you made any updates to your site?

Secondly have you tested your form by sending a test data to see if the received form data contains the message content?



Yes many updates, but the form html itself wasn’t changed substantially:

<form name="contact" action="success.html" netlify>
                <textarea style="width:100%;height:5rem;" placeholder="Drop some deets here xxx"></textarea>
                <button type="submit">Send</button>

I just sent a test message and the Netlify UI shows the message as reiceved at the right time etc but there is no message content.
Old messages that were sent previously, which I explicitly remember seeing in Netlify’s interface before, are only there now as empty messages.

Hi @00ffbb,

I checked our database, and I don’t see any form submission (total 20) having any data. I just checked your website and tried submitting some data, and this is the payload I see:

You’re not posting any data to the server - just the form name. This is the form I filled:


With the given setup, this looks expected to me.

1 Like

Ok, so it looks like the update to the code may have changed the submission format so it’s no longer submitting the textarea content (but it’s not clear how or why?), and as soon as a form changes it’s submission format, netlify deletes any old form content that doesn’t match the new form submission format?

Old form data should exist and it still appears in our database. Are you not seeing any form submission? Could you share a screenshot of the UI?

So I click ‘expand all’ to see the message content but it’s all blank, even ones many months ago when the form was working as I intended.

Something weird is going on. I’m seeing the data in our database, but it’s not showing up in the UI. I have asked the devs to take a look.

1 Like