Fonts & images(svg) are not loaded on netlify when i deploy them

netlify :
github : GitHub - Am1rreza/Digitize: Digitize(Shopping website) project using Tailwind CSS (Responsive)

my images and fonts are not shown on site but in my local host evrything is fine
i am using tailwind css to this project

deploy log

Hi @Am1rreza can you please upload a screenshot of your build settings… this would help us a lot.

You can find them here
Site settings. > Build and deploy > Build settings

1 Like

@Am1rreza @kylesloper seems i’m having the same issue. I’ve gone and recently spun up a new project looking to use the latest versions of Qwik, Netlify CLI and related libraries and am finding that my static assets in my /public folder are not accessible after a build.

Things work fine locally when using the npm run dev (vite --mode ssr) however running locally with netlify dev --live or deploying the site to Netlify surfaces the issue with the 404 on all my static images.

Attaching screenshots for more context.

originally posted the incorrect screenshot of my package.json

@Am1rreza not sure if this is your fix as well but I just updated from 0.0.122 → 0.0.123 and my images are now appearing when running netlify dev --live. Going to deploy and confirm there as well.

Images are appearing on deployed site as well. Am1rreza I looked at your codebase and looks like we’re on a different stack so my apologies for polluting your post with what may be a different issue than you’re experiencing.

1 Like


You’re link to the assets folder:

but there’s no assets folder in your repo.

I put the assets folder in .gitignore, but it didn’t make a difference if I didn’t put it because I tried and the photos still didn’t load.

There’s still no assets folder in your repo. It won’t work until it is added there.

now assets folder added . but still not working

You’re deploying the site from the public folder: Netlify App, so the assets folder should be inside public.

Thanks for your help, but it still doesn’t work
this is the new address :

You now changed your URLs to /public/assets:

The URLs should be only /assets..., but files should remain in /pubic/assets.

thaaanks a lot , my images problem fixed
but my fonts still are not shown
and i dont know how i change url in my fontiran.css file that starts with assets
(sorry about my grammar problems)

Change all the URLs here: Digitize/tailwind.css at master · Am1rreza/Digitize · GitHub to start with /assets instead of ../public.

1 Like

Thank you for your help
Everything fixed

1 Like