Home
Support Forums

Fjord Gatsby build error

I’ve experienced the same error on two Fjord Gatsby sites I deployed tonight as well.
I’ve seen in the past that this is a Netlify Service Error rather than anything user defined.

Site URLs
https://app.stackbit.com/studio/611c89e19aa33200cb3d7f9a?previewToken=c7d4d15f-8eb3-4f27-af3d-7dc81f2451bd

https://app.stackbit.com/studio/611c40fe0fdff600beb7b37c?previewToken=5b99f626-c876-44bf-838f-3126f3015403

Here is my full deploy log. It is a vanilla build
9:06:43 PM: Build ready to start
9:06:45 PM: build-image version: fa439ad1ab9393b2c0d449d8d7c033927683f4b0
9:06:45 PM: build-image tag: v4.3.0
9:06:45 PM: buildbot version: b804dff13c52d65303f0ba1445af1695479d4e08
9:06:46 PM: Fetching cached dependencies
9:06:46 PM: Failed to fetch cache, continuing with build
9:06:46 PM: Starting to prepare the repo for build
9:06:46 PM: No cached dependencies found. Cloning fresh repo
9:06:46 PM: git clone https://github.com/donnay/successful-tomato
9:06:48 PM: Preparing Git Reference refs/heads/master
9:06:48 PM: Parsing package.json dependencies
9:06:49 PM: Different publish path detected, going to use the one specified in the Netlify configuration file: ‘public’ versus ‘/’ in the Netlify UI
9:06:49 PM: Different build command detected, going to use the one specified in the Netlify configuration file: ‘npm run build’ versus ‘’ in the Netlify UI
9:06:49 PM: Starting build script
9:06:49 PM: Installing dependencies
9:06:49 PM: Python version set to 2.7
9:06:50 PM: Downloading and installing node v16.7.0…
9:06:50 PM: Downloading https://nodejs.org/dist/v16.7.0/node-v16.7.0-linux-x64.tar.xz
9:06:50 PM: Computing checksum with sha256sum
9:06:50 PM: Checksums matched!
9:06:53 PM: Now using node v16.7.0 (npm v7.20.3)
9:06:53 PM: Started restoring cached build plugins
9:06:53 PM: Finished restoring cached build plugins
9:06:53 PM: Attempting ruby version 2.7.2, read from environment
9:06:55 PM: Using ruby version 2.7.2
9:06:55 PM: Using PHP version 8.0
9:06:55 PM: Started restoring cached node modules
9:06:55 PM: Finished restoring cached node modules
9:06:55 PM: Installing NPM modules using NPM version 7.20.3
9:06:58 PM: npm WARN old lockfile
9:06:58 PM: npm WARN old lockfile The package-lock.json file was created with an old version of npm,
9:06:58 PM: npm WARN old lockfile so supplemental metadata must be fetched from the registry.
9:06:58 PM: npm WARN old lockfile
9:06:58 PM: npm WARN old lockfile This is a one-time fix-up, please be patient…
9:06:58 PM: npm WARN old lockfile
9:07:27 PM: npm WARN deprecated urix@0.1.0: Please see https://github.com/lydell/urix#deprecated
9:07:27 PM: npm WARN deprecated har-validator@5.1.5: this library is no longer supported
9:07:28 PM: npm WARN deprecated resolve-url@0.2.1: https://github.com/lydell/resolve-url#deprecated
9:07:29 PM: npm WARN deprecated uuid@3.4.0: Please upgrade to version 7 or higher. Older versions may use Math.random() in certain circumstances, which is known to be problematic. See There’s Math.random(), and then there’s Math.random() · V8 for details.
9:07:31 PM: npm WARN deprecated querystring@0.2.0: The querystring API is considered Legacy. new code should use the URLSearchParams API instead.
9:07:31 PM: npm WARN deprecated request@2.88.2: request has been deprecated, see Request’s Past, Presen
9:07:32 PM: npm WARN deprecated chokidar@2.1.8: Chokidar 2 will break on node v14+. Upgrade to chokidar 3 with 15x less dependencies.
9:07:33 PM: npm WARN deprecated chokidar@2.1.8: Chokidar 2 will break on node v14+. Upgrade to chokidar 3 with 15x less dependencies.
9:07:34 PM: npm WARN deprecated debug@4.1.1: Debug versions >=3.2.0 <3.2.7 || >=4 <4.3.1 have a low-severity ReDos regression when used in a Node.js environment. It is recommended you upgrade to 3.2.7 or 4.3.1. (ReDos Vulnerability Regr)
9:07:34 PM: npm WARN deprecated debug@4.1.1: Debug versions >=3.2.0 <3.2.7 || >=4 <4.3.1 have a low-severity ReDos regression when used in a Node.js environment. It is recommended you upgrade to 3.2.7 or 4.3.1. (ReDos Vulnerability Regr)
9:07:35 PM: npm WARN deprecated debug@4.1.1: Debug versions >=3.2.0 <3.2.7 || >=4 <4.3.1 have a low-severity ReDos regression when used in a Node.js environment. It is recommended you upgrade to 3.2.7 or 4.3.1. (ReDos Vulnerability Regr)
9:07:35 PM: npm WARN deprecated querystring@0.2.1: The querystring API is considered Legacy. new code should use the URLSearchParams API instead.
9:07:45 PM: npm WARN deprecated eslint-loader@2.2.1: This loader has been deprecated. Please use eslint-webpack-plugin
9:07:48 PM: npm WARN deprecated debug@4.1.1: Debug versions >=3.2.0 <3.2.7 || >=4 <4.3.1 have a low-severity ReDos regression when used in a Node.js environment. It is recommended you upgrade to 3.2.7 or 4.3.1. (ReDos Vulnerability Regr)
9:07:50 PM: npm WARN deprecated babel-eslint@10.1.0: babel-eslint is now @babel/eslint-parser. This package will no longer receive updates.
9:07:51 PM: npm WARN deprecated @types/vfile-message@2.0.0: This is a stub types definition. vfile-message provides its own type definitions, so you do not need this installed.
9:07:51 PM: npm WARN deprecated chokidar@2.1.8: Chokidar 2 will break on node v14+. Upgrade to chokidar 3 with 15x less dependencies.
9:07:52 PM: npm WARN deprecated @hapi/topo@3.1.6: This version has been deprecated and is no longer supported or maintained
9:07:52 PM: npm WARN deprecated @hapi/bourne@1.3.2: This version has been deprecated and is no longer supported or maintained
9:07:52 PM: npm WARN deprecated @hapi/address@2.1.4: Moved to ‘npm install @sideway/address’
9:07:54 PM: npm WARN deprecated @hapi/hoek@8.5.1: This version has been deprecated and is no longer supported or maintained
9:07:54 PM: npm WARN deprecated tar@2.2.2: This version of tar is no longer supported, and will not receive security updates. Please upgrade asap.
9:07:54 PM: npm WARN deprecated axios@0.20.0: Critical security vulnerability fixed in v0.21.1. For more information, see https://github.com/axios/axios/pull/3410
9:07:54 PM: npm WARN deprecated @hapi/joi@15.1.1: Switch to ‘npm install joi’
9:08:06 PM: npm WARN deprecated core-js@2.6.12: core-js@<3.3 is no longer maintained and not recommended for usage due to the number of issues. Because of the V8 engine whims, feature detection in old core-js versions could cause a slowdown up to 100x even if nothing is polyfilled. Please, upgrade your dependencies to the actual version of core-js.

The log finished with these lines:

9:10:34 PM: npm ERR! rm -rf “Release/sass.a” && cp -af “Release/obj.target/src/sass.a” “Release/sass.a”

9:10:34 PM: npm ERR! g++ ‘-DNODE_GYP_MODULE_NAME=binding’ ‘-DUSING_UV_SHARED=1’ ‘-DUSING_V8_SHARED=1’ ‘-DV8_DEPRECATION_WARNINGS=1’ ‘-DV8_DEPRECATION_WARNINGS’ ‘-DV8_IMMINENT_DEPRECATION_WARNINGS’ ‘-D_GLIBCXX_USE_CXX11_ABI=1’ ‘-D_LARGEFILE_SOURCE’ ‘-D_FILE_OFFSET_BITS=64’ ‘-D__STDC_FORMAT_MACROS’ ‘-DOPENSSL_NO_PINSHARED’ ‘-DOPENSSL_THREADS’ ‘-DBUILDING_NODE_EXTENSION’ -I/opt/buildhome/.node-gyp/16.7.0/include/node -I/opt/buildhome/.node-gyp/16.7.0/src -I/opt/buildhome/.node-gyp/16.7.0/deps/openssl/config -I/opt/buildhome/.node-gyp/16.7.0/deps/openssl/openssl/include -I/opt/buildhome/.node-gyp/16.7.0/deps/uv/include -I/opt/buildhome/.node-gyp/16.7.0/deps/zlib -I/opt/buildhome/.node-gyp/16.7.0/deps/v8/include -I…/…/nan -I…/src/libsass/include -fPIC -pthread -Wall -Wextra -Wno-unused-parameter -m64 -O3 -fno-omit-frame-pointer -fno-rtti -fno-exceptions -std=gnu++14 -std=c++0x -MMD -MF ./Release/.deps/Release/obj.target/binding/src/binding.o.d.raw -c -o Release/obj.target/binding/src/binding.o …/src/binding.cpp

9:10:34 PM: npm ERR! make: Leaving directory ‘/opt/build/repo/node_modules/node-sass/build’

9:10:34 PM: npm ERR! gyp info it worked if it ends with ok

9:10:34 PM: npm ERR! gyp verb cli [

9:10:34 PM: npm ERR! gyp verb cli ‘/opt/buildhome/.nvm/versions/node/v16.7.0/bin/node’,

9:10:34 PM: npm ERR! gyp verb cli ‘/opt/build/repo/node_modules/node-gyp/bin/node-gyp.js’,

9:10:34 PM: npm ERR! gyp verb cli ‘rebuild’,

9:10:34 PM: npm ERR! gyp verb cli ‘–verbose’,

9:10:34 PM: npm ERR! gyp verb cli ‘–libsass_ext=’,

9:10:34 PM: npm ERR! gyp verb cli ‘–libsass_cflags=’,

9:10:34 PM: npm ERR! gyp verb cli ‘–libsass_ldflags=’,

9:10:34 PM: npm ERR! gyp verb cli ‘–libsass_library=’

9:10:34 PM: npm ERR! gyp verb cli ]

9:10:34 PM: npm ERR! gyp info using node-gyp@3.8.0

9:10:34 PM: npm ERR! gyp info using node@16.7.0 | linux | x64

9:10:34 PM: npm ERR! gyp verb command rebuild

9:10:34 PM: npm ERR! gyp verb command clean

9:10:34 PM: npm ERR! gyp verb clean removing “build” directory

9:10:34 PM: npm ERR! gyp verb command configure

9:10:34 PM: npm ERR! gyp verb check python checking for Python executable “python2” in the PATH

9:10:34 PM: npm ERR! gyp verb which succeeded python2 /opt/buildhome/python2.7/bin/python2

9:10:34 PM: npm ERR! gyp verb check python version /opt/buildhome/python2.7/bin/python2 -c "import sys; print "2.7.18 npm ERR! gyp verb check python version .%s.%s" % sys.version_info[:3];" returned: %j

9:10:34 PM: npm ERR! gyp verb get node dir no --target version specified, falling back to host node version: 16.7.0

9:10:34 PM: npm ERR! gyp verb command install [ ‘16.7.0’ ]

9:10:34 PM: npm ERR! gyp verb install input version string “16.7.0”

9:10:34 PM: npm ERR! gyp verb install installing version: 16.7.0

9:10:34 PM: npm ERR! gyp verb install --ensure was passed, so won’t reinstall if already installed
npm ERR! gyp verb install version not already installed, continuing with install 16.7.0

9:10:34 PM: npm ERR! gyp verb ensuring nodedir is created /opt/buildhome/.node-gyp/16.7.0

9:10:34 PM: npm ERR! gyp verb created nodedir /opt/buildhome/.node-gyp

9:10:34 PM: npm ERR! gyp http GET https://nodejs.org/download/release/v16.7.0/node-v16.7.0-headers.tar.gz

9:10:34 PM: npm ERR! gyp http 200 https://nodejs.org/download/release/v16.7.0/node-v16.7.0-headers.tar.gz

9:10:34 PM: npm ERR! gyp verb extracted file from tarball include/node/common.gypi

9:10:34 PM: npm ERR! gyp verb extracted file from tarball include/node/config.gypi

9:10:34 PM: npm ERR! gyp verb extracted file from tarball include/node/node.h

9:10:34 PM: npm ERR! gyp verb extracted file from tarball include/node/node_api.h

9:10:34 PM: npm ERR! gyp verb extracted file from tarball include/node/js_native_api.h

9:10:34 PM: npm ERR! gyp verb extracted file from tarball include/node/js_native_api_types.h

9:10:34 PM: npm ERR! gyp verb extracted file from tarball include/node/node_api_types.h

9:10:34 PM: npm ERR! gyp verb extracted file from tarball include/node/node_buffer.h

9:10:34 PM: npm ERR! gyp verb extracted file from tarball include/node/node_object_wrap.h

9:10:34 PM: npm ERR! gyp verb extracted file from tarball include/node/node_version.h

9:10:34 PM: npm ERR! gyp verb extracted file from tarball include/node/v8-internal.h

9:10:34 PM: npm ERR! gyp verb extracted file from tarball include/node/v8config.h

9:10:34 PM: npm ERR! gyp verb extracted file from tarball include/node/v8-profiler.h

9:10:34 PM: npm ERR! gyp verb extracted file from tarball include/node/v8-platform.h

9:10:34 PM: npm ERR! gyp verb extracted file from tarball include/node/v8-version.h

9:10:34 PM: npm ERR!Error during NPM install

9:10:34 PM: Build was terminated: Build script returned non-zero exit code: 1

9:10:34 PM: Failing build: Failed to build site

9:10:34 PM: Finished processing build request in 3m48.983222188s

I’m receiving the same error if I pick SSG as Gatsby or Next.JS

I have moved your posts to a new thread @kevind as the reason behind your error is different to the thread you originally posted in, and the OP of that thread has now marked it solved.

The first part of your log finishes at 9:08:06 PM and the next part begins at 9:10:34 PM. Was there nothing that happened between these times? Perhaps you could set your logs to public and share a link to the latest failed deploy.

Repository: github.com/donnay/panoramic-pine
Deploy log visibility; Logs are public

Here is a link to the deploy details: Netlify App

hey @kevind , does this build locally? :thinking:

The issue has been resolved!
Set Node_Version environment variable in netlify to 14. Yes, it builds locally