FetchEvent.respondWith received an error: returned response is null


I am currently facing a problem with the Netlify host because after doing a Gatsby build, for a Gatsby site, I find myself with an error message This message also appears when I do a build after cleaning the cache. Here is the error message: FetchEvent.respondWith received an error: returned response is null. I searched the internet but could not find a solution to correct this problem which only occurs on Safari, on iOS. my site is at the following address: https://capriati-peinture.netlify.app I have my repository GitHub - Pataco80/capriati-peinture. On my computer everything is fine. As for modules, I have the latest at the version level. At compile time there is no error and at the end it gives me a preview of the site. Everything was OK there, except I have this message popping up and I can’t resolve it despite my internet research. Can anyone help me ? I have been on it for a few days and have to publish this site for a client soon. Thank you in advance for your support.

hi there, sorry to be slow to reply. Are you still seeing this error? are you able to reproduce it in an incognito window?

Hello, I’m sorry I didn’t see your answer sooner.

I still have the same problem for the website. I took a closer look at the problem but I can’t seem to resolve it. I have the chrome lightouse which tells me that there is a problem with the start_url, I even tried to put an .htaccess file provided by my shared host for the direct test on my own domain name. The first time everything was ok, but when refreshing the page, the error is displayed. it tells me that there is a problem with the (webKitServiceWorker: 0) right after the message. I tried the incognito window, it’s still the same. I am lost, I do not understand because I had taken courses on it and I had never had this in the other sites that I learned on Udemy.

Thank you for your help and sorry for the delay in responding. I put the site at the root of my personal site at the following address: www.dvwdesign.ch

Hey there,
I believe this is a service worker issue, as you mentioned. Gatsby configures this in its gatsby-plugin-offline plugin- can you please try removing that plugin from your gatsby config, here-ish:

I solved the problem and obviously didn’t post a message about it. I put the default configuration I removed all these small configurations that I was offered in a post dedicated to this subject. Suddenly everything is back to normal and things are going really well.

1 Like

That’s great news, glad to hear it :slight_smile: