Failing to deploy my portfolio

PLEASE help us help you by writing a good post!

I m trying my best the last 72 hours to deploy my portfolio site using Netlify.
I was thinking to find other solutions or other platforms but I m using Netlify for 2 years now and this is the first time that I m having such kind of problem.

I posting down here the info from my deploy log:
7:25:54 PM: Build ready to start
7:25:56 PM: build-image version: 53b83b6bede2920f236b25b6f5a95334320dc849
7:25:56 PM: build-image tag: v3.6.0
7:25:56 PM: buildbot version: 8ae026ef4905d9174e416775c6b64aa19950569b
7:25:56 PM: Building without cache
7:25:56 PM: Starting to prepare the repo for build
7:25:57 PM: No cached dependencies found. Cloning fresh repo
7:25:57 PM: git clone https://github.com/OldDognoob/DPortfolio
7:25:58 PM: Preparing Git Reference refs/heads/master
7:26:00 PM: Different build dir detected, going to use the one specified in the Netlify configuration file: β€˜my-portfolio’ versus β€˜/my-portfolio/’ in the Netlify UI
7:26:00 PM: Starting build script
7:26:00 PM: Installing dependencies
7:26:00 PM: Python version set to 2.7
7:26:01 PM: v12.18.0 is already installed.
7:26:02 PM: Now using node v12.18.0 (npm v6.14.4)
7:26:02 PM: Started restoring cached build plugins
7:26:02 PM: Finished restoring cached build plugins
7:26:02 PM: Attempting ruby version 2.7.1, read from environment
7:26:03 PM: Using ruby version 2.7.1
7:26:04 PM: Using PHP version 5.6
7:26:04 PM: Started restoring cached node modules
7:26:04 PM: Finished restoring cached node modules
7:26:04 PM: Started restoring cached yarn cache
7:26:04 PM: Finished restoring cached yarn cache
7:26:04 PM: Installing yarn at version 1.22.4
7:26:04 PM: Installing Yarn!
7:26:04 PM: > Downloading tarball…
7:26:04 PM: [1/2]: https://yarnpkg.com/downloads/1.22.4/yarn-v1.22.4.tar.gz --> /tmp/yarn.tar.gz.85xPqB6zxh
7:26:04 PM: % Total % Received % Xferd Average Speed Time Time Time Current
7:26:04 PM: Dload Upload Total Spent Left Speed
7:26:05 PM: 0 0 0 0 0 0 0 0 --:–:-- --:–:-- --:–:-- 0
7:26:05 PM: 0 80 0 0 0 0 0 0 --:–:-- --:–:-- --:–:-- 0
7:26:05 PM: 100 80 100 80 0 0 85 0 --:–:-- --:–:-- --:–:-- 85
7:26:05 PM: 100 93 100 93 0 0 72 0 0:00:01 0:00:01 --:–:-- 72
7:26:05 PM: 100 643 100 643 0 0 412 0 0:00:01 0:00:01 --:–:-- 412
7:26:06 PM: 2 1215k 2 33354 0 0 17964 0 0:01:09 0:00:01 0:01:08 17964
7:26:06 PM: 100 1215k 100 1215k 0 0 607k 0 0:00:02 0:00:02 --:–:-- 8158k
7:26:06 PM: [2/2]: https://yarnpkg.com/downloads/1.22.4/yarn-v1.22.4.tar.gz.asc --> /tmp/yarn.tar.gz.85xPqB6zxh.asc
7:26:06 PM: 100 84 100 84 0 0 1068 0 --:–:-- --:–:-- --:–:-- 1068
7:26:06 PM: 100 97 100 97 0 0 906 0 --:–:-- --:–:-- --:–:-- 906
7:26:06 PM: 100 647 100 647 0 0 4595 0 --:–:-- --:–:-- --:–:-- 4595
7:26:06 PM: 100 1028 100 1028 0 0 5629 0 --:–:-- --:–:-- --:–:-- 5629
7:26:06 PM: > Verifying integrity…
7:26:06 PM: gpg: Signature made Mon 09 Mar 2020 03:52:13 PM UTC using RSA key ID 69475BAA
7:26:06 PM: gpg: Good signature from β€œYarn Packaging yarn@dan.cx”
7:26:06 PM: gpg: WARNING: This key is not certified with a trusted signature!
7:26:06 PM: gpg: There is no indication that the signature belongs to the owner.
7:26:06 PM: Primary key fingerprint: 72EC F46A 56B4 AD39 C907 BBB7 1646 B01B 86E5 0310
7:26:06 PM: Subkey fingerprint: 6D98 490C 6F1A CDDD 448E 4595 4F77 6793 6947 5BAA
7:26:06 PM: > GPG signature looks good
7:26:06 PM: > Extracting to ~/.yarn…
7:26:06 PM: > Adding to PATH... 7:26:06 PM: > Successfully installed Yarn 1.22.4! Please open another terminal where the `yarn` command will now be available. 7:26:07 PM: Installing NPM modules using Yarn version 1.22.4 7:26:07 PM: yarn install v1.22.4 7:26:07 PM: [1/4] Resolving packages... 7:26:10 PM: [2/4] Fetching packages... 7:26:46 PM: info fsevents@2.2.1: The platform "linux" is incompatible with this module. 7:26:46 PM: info "fsevents@2.2.1" is an optional dependency and failed compatibility check. Excluding it from installation. 7:26:46 PM: info fsevents@1.2.9: The platform "linux" is incompatible with this module. 7:26:46 PM: info "fsevents@1.2.9" is an optional dependency and failed compatibility check. Excluding it from installation. 7:26:46 PM: info fsevents@2.1.3: The platform "linux" is incompatible with this module. 7:26:46 PM: info "fsevents@2.1.3" is an optional dependency and failed compatibility check. Excluding it from installation. 7:26:46 PM: [3/4] Linking dependencies... 7:26:46 PM: warning " > @testing-library/user-event@12.2.2" has unmet peer dependency "@testing-library/dom@>=7.21.4". 7:26:46 PM: warning " > bootstrap@4.5.3" has unmet peer dependency "jquery@1.9.1 - 3". 7:26:46 PM: warning " > bootstrap@4.5.3" has unmet peer dependency "popper.js@^1.16.1". 7:26:46 PM: warning "react-bootstrap > @restart/hooks@0.3.25" has incorrect peer dependency "react@^16.8.0". 7:26:46 PM: warning "react-scripts > @typescript-eslint/eslint-plugin > tsutils@3.17.1" has unmet peer dependency "typescript@>=2.8.0 || >= 3.2.0-dev || >= 3.3.0-dev || >= 3.4.0-dev || >= 3.5.0-dev || >= 3.6.0-dev || >= 3.6.0-beta || >= 3.7.0-dev || >= 3.7.0-beta". 7:26:46 PM: warning " > react-scroll@1.8.1" has incorrect peer dependency "react@^15.5.4 || ^16.0.0". 7:26:46 PM: warning " > react-scroll@1.8.1" has incorrect peer dependency "react-dom@^15.5.4 || ^16.0.0". 7:27:19 PM: [4/4] Building fresh packages... 7:27:21 PM: success Saved lockfile. 7:27:21 PM: Done in 73.92s. 7:27:21 PM: NPM modules installed using Yarn 7:27:22 PM: Started restoring cached go cache 7:27:22 PM: Finished restoring cached go cache 7:27:22 PM: go version go1.14.4 linux/amd64 7:27:22 PM: go version go1.14.4 linux/amd64 7:27:22 PM: Installing missing commands 7:27:22 PM: Verify run directory 7:27:24 PM: ​ 7:27:24 PM: ──────────────────────────────────────────────────────────────── 7:27:24 PM: Netlify Build 7:27:24 PM: ──────────────────────────────────────────────────────────────── 7:27:24 PM: ​ 7:27:24 PM: ❯ Version 7:27:24 PM: @netlify/build 8.0.0 7:27:24 PM: ​ 7:27:24 PM: ❯ Flags 7:27:24 PM: deployId: 5ff34fa2fb4fd85411ab3dc9 7:27:24 PM: mode: buildbot 7:27:24 PM: ​ 7:27:24 PM: ❯ Current directory 7:27:24 PM: /opt/build/repo/my-portfolio 7:27:24 PM: ​ 7:27:24 PM: ❯ Config file 7:27:24 PM: No config file was defined: using default values. 7:27:24 PM: ​ 7:27:24 PM: ❯ Context 7:27:24 PM: production 7:27:24 PM: ​ 7:27:24 PM: ──────────────────────────────────────────────────────────────── 7:27:24 PM: 1. Build command from Netlify app 7:27:24 PM: ──────────────────────────────────────────────────────────────── 7:27:24 PM: ​ 7:27:24 PM: npm run build
7:27:24 PM: > my-portfolio@0.1.0 build /opt/build/repo/my-portfolio
7:27:24 PM: > react-scripts build
7:27:26 PM: Creating an optimized production build…
7:27:30 PM: Browserslist: caniuse-lite is outdated. Please run next command yarn upgrade
7:28:02 PM: Compiled successfully.
7:28:02 PM:
7:28:02 PM: File sizes after gzip:
7:28:02 PM: 98.84 KB build/static/js/2.4d5f4437.chunk.js
7:28:02 PM: 22.69 KB build/static/css/2.67a8f8f6.chunk.css
7:28:02 PM: 3.01 KB build/static/js/main.2ecfcb8e.chunk.js
7:28:02 PM: 1.53 KB build/static/css/main.1d8cf393.chunk.css
7:28:02 PM: 777 B build/static/js/runtime-main.4be9c4de.js
7:28:02 PM: The project was built assuming it is hosted at /.
7:28:02 PM: You can control this with the homepage field in your package.json.
7:28:02 PM: The build folder is ready to be deployed.
7:28:02 PM: You may serve it with a static server:
7:28:02 PM: yarn global add serve
7:28:02 PM: serve -s build
7:28:02 PM: Find out more about deployment here:
7:28:02 PM: https://cra.link/deployment
7:28:02 PM: ​
7:28:02 PM: (build.command completed in 38.3s)
7:28:02 PM: ​
7:28:02 PM: ────────────────────────────────────────────────────────────────
7:28:02 PM: Netlify Build Complete
7:28:02 PM: ────────────────────────────────────────────────────────────────
7:28:02 PM: ​
7:28:02 PM: (Netlify Build completed in 38.4s)
7:28:02 PM: Caching artifacts
7:28:02 PM: Started saving node modules
7:28:02 PM: Finished saving node modules
7:28:02 PM: Started saving build plugins
7:28:02 PM: Finished saving build plugins
7:28:02 PM: Started saving yarn cache
7:28:02 PM: Finished saving yarn cache
7:28:02 PM: Started saving pip cache
7:28:02 PM: Finished saving pip cache
7:28:02 PM: Started saving emacs cask dependencies
7:28:02 PM: Finished saving emacs cask dependencies
7:28:02 PM: Started saving maven dependencies
7:28:02 PM: Finished saving maven dependencies
7:28:02 PM: Started saving boot dependencies
7:28:02 PM: Finished saving boot dependencies
7:28:02 PM: Started saving rust rustup cache
7:28:02 PM: Finished saving rust rustup cache
7:28:02 PM: Started saving rust cargo bin cache
7:28:02 PM: Finished saving rust cargo bin cache
7:28:02 PM: Started saving go dependencies
7:28:02 PM: Finished saving go dependencies
7:28:05 PM: Build script success
7:28:05 PM: Starting to deploy site from β€˜β€™
7:28:05 PM: Creating deploy tree
7:28:05 PM: Creating deploy upload records
7:28:05 PM: 0 new files to upload
7:28:05 PM: 0 new functions to upload
7:28:05 PM: Starting post processing
7:28:05 PM: Post processing - HTML
7:28:05 PM: Post processing - header rules
7:28:05 PM: Post processing - redirect rules
7:28:05 PM: Post processing done
7:28:05 PM: Site is live :sparkles:
7:28:37 PM: Finished processing build request in 2m40.713994152s

This is the netlify site name: https://5ff34fa2fb4fd85411ab3dc9--cocky-heyrovsky-53f50a.netlify.app/

Information from the page Continous Deployment:

If you need anything else pls ask me to send more info.
Thank you in advance

  • we need to know your netlify site name. Example: gifted-antelope-58b104.netlify.app
  • DNS issues? Tell us the custom domain, tell us the error message! We can’t help if we don’t know your domain.
  • Build problems? Link or paste the FULL build log & build settings screenshot

The better the post - the faster the answer.

It looks like the publish directory needs to be set to build here:

Currently there is no publish directory set so the base of the repo is being used instead. Setting the publish directory to β€œbuild” should be all that is required to fix this.

If there are other questions or concerns, please let us know.

Ok, I would like to thank you for giving me this solution. After 12 failed I finally got it right it is actually:
/you repo/build.
It would be nice for the Netlify community to have a small video showing how you can overcome this kind of problem and not leave people to fight for days how to figure out the solution. I know that you are here to help us people like me, new but on the other hand, it will save time.
Nevertheless, as we say in my country Thank you, my friend, for your help.
Thanks in advance.
Yours Dimos

1 Like

hi Dimos, glad you got it working! the settings can vary quite a bit from person to person so it is a little tricky to give advice that always works - but if you have thoughts on how we can make things better in a general way, feedback is always welcome!