Home
Support Forums

Failed to load resource--which is React?

I set up https://kind-poincare-cabd5e.netlify.app/ with a continuous build (repo: https://github.com/CactusWren2020/emotion-app ), but there are some weird issues.

  1. feelings: Failed to load resource: the server responded with a status of 404 () feelings:1

A message like this is on every page. The first line of every page is where I import React–does this mean React isn’t being imported?

2. A quiz is working erratically. It uses this.state.answers to keep track of “yes” answers, and this.state.currentQuestion to keep track of which question (array index) the user is on. For some reason, the this.state.answers is being updated, but this.state.currentQuestion is not. As a result, the quiz does not advance.
(got this working by putting the increment before the variable instead of after it. However, it worked normally on my local build.

  1. Get Page Not Found 404 while navigating or refreshing on valid links.

howdy, does this build locally? that’d be the first thing to check.

This Support Guide contains a ton of useful debugging tips that can likely help you solve your problem :slight_smile:

If you are still having problems, please provide as much information as you can on what you have already tried, what your build settings are, your package.json, etc. Thanks!