Error: No prebuild or local build of @parcel/watcher found

I get this error in build step of our gatsby project (latest version 5.11.0). I was able to build it locally with netlify CLI build.

8:39:32 AM: error There was an unhandled error during compilation for /opt/build/repo. Please run the command with the --verbose flag again.
8:39:32 AM: No prebuild or local build of @parcel/watcher found. Tried @parcel/watcher-linux-x64-glibc. Please ensure it is installed (don’t use --no-optional when installing with npm). Otherwise it is possible we don’t support your platform yet. If this is the case, please report an issue to GitHub - parcel-bundler/watcher: 👀 A native C++ Node module for querying and subscribing to filesystem events.

any clue how to fix it?

Hi @HoppyGo,

Thanks for reaching out!

Could you provide us with the URL or name of that site that you’re having this build issue with? If you could provide the site name such as that’ll help us look into this issue. Thanks!

  • it is now on

  • tried to add “npm rebuild && npm build” in the netlify.toml - solution I came across according to the forum here with some related task mentioning C libs not working/building correctly. I was able to make it complete the CI build by additionally adding these packages to our deps and gatsby config:

    @netlify/plugin-gatsby”: “^3.7.1”,
    “gatsby-plugin-netlify”: “^5.1.0”,

Right now it is deployed but we can see that the app does not work correctly, API requests are not sent, etc. so we are further investigating what caused it - if it might be caused by those deps changing something. Could you give us any advice/clue? Thank you.


  • David K., frontend developer at Skoda X

How can we replicate the API error? Can you please let us know, so we can check?

Hi, I’m facing the same issue.

You can goto (this create as js sandbox template with Parcel as bundler) and try deploye that to replicate this. doesn’t open