My site name is:
You can replace 589 with any numbers, as we build preview environments on a per pull request basis so there are many relevant site names/URLs.

Long story short: My team uses Netlify to host ‘preview environments’ that allow our product team to use new features before approving pull requests (bad ass, I know, great service).

I used to live in New York City and never had any issue connecting to Netlify. I moved to Maine (USA) one month ago and I can no longer access any Netlify URL.

I get this error message no matter what browser and no matter if viewing publicly or in incognito mode (even CURL): This site can’t provide a secure sent an invalid response. ERR_SSL_PROTOCOL_ERROR

My DevOps team looked into this issue and determined there is nothing we can do on our end to mediate a fix.

It was mentioned to me that this was due to the CDNs utilized by Netlify for my geographic region.

I would like to use Netlify again, please help!

This sounds like a local issue. Are you able to use a VPN to connect?

It’s not possible for us to troubleshoot local configuration issues, you might be able to seek help from your ISP.

Hi @hrishikesh thanks for the feedback. I appreciate the help getting down to the bottom on this issue.
To rule out what you suggested, I tried loading the same URLs that will not work on my wifi on my cell phone using only a cellular network, no wifi at all (wifi turned completely off) and I get the same error message.

Hi, I am not seeing this error, and I tried with and without a VPN. Are you still experiencing this issue? I can’t seem to reproduce. Have your tried clearing your browser cache?

Yes @SamO still seeing it on any browser I use (Chrome, FF, Safari). I am seeing it when using web or cell service. Yes I cleared all history and related caches and even tried in incognito mode which doesn’t store a cache. I really appreciate you trying to help. I wonder what steps I can take to provide you with more info to test against.

I went to a coffee shop and it works there on their public wifi. So it must be localized to my home for some odd reason. Thanks everyone for helping me debug.

Glad you found your solution! Thanks for coming back and sharing this with the community.