Email Forward from Hover

I’m trying to add my MX info from Hover (my domain) but I am getting an error when I send a test email:

Message blocked
Your message to has been blocked. See technical details below for more information.
The response from the remote server was:

554 5.7.1 <>: Recipient address rejected: Access denied

Hover keeps telling me to connect support from Netlify but I have a free account so I am stuck.

This is what I have set up:

Can someone please help me figure out why my email is not before forwarded??

Hi there! This Support guide is the best place to get started with information on dealing with email on Netlify:

If you still have questions after working through this guide, we suggest you try the search, as many people have already asked questions on this topic. If still no luck, let us know and we can troubleshoot with you.

I don’t want to use a mailbox service, I wanted to use a mail forward from my domain. I haven’t been able to find a post that matches my error, it seems everyone is using a mailbox service.

I am having the same issue! Last week I set up my Netlify site to successfully point to my Hover domain, but my email is not forwarding. I made sure to copy over the DNS records, including the MX records.

Whenever I send an email, I receive this:

Screen Shot 2020-07-24 at 9.41.25 AM

Please help us.

Hi, @erinesullivan and @erinesullivan. We have a topic about issues with email services here:

To summarize, our support team doesn’t know what the correct DNS records are for your mail service. We need you to tell us what those are and, once we know that, we can troubleshoot to be sure the DNS records are working.

Again, we are happy to troubleshoot the DNS service as those are systems we are responsible for and control. We cannot troubleshoot the email service itself because we don’t administer those systems.

I don’t show the DNS record above configured anymore. It appears to have been deleted.

If there are other questions or if specific DNS records are not working, please let us know.

Hover just got back to me, try

Hi, @erkdonovan. I’m not sure what you mean by “try”. That domain name does return an A record when I query for it:

$ dig  +noall +answer

; <<>> DiG 9.10.6 <<>> +noall +answer
;; global options: +cmd 1371	IN A

That DNS record above isn’t at Netlify and I’m not sure why you are mentioning it.

Are you trying to create a CNAME DNS record for a custom domain at Netlify which points to that domain name?

I think you probably need to some DNS records to get the email service working. If so, please create those records first. Then, if those records are not working, please let us know what records you tried to create and what you are seeing instead.

If there are any questions, please let us know.

My suggestion was to Erin. Hover had me change my MX record to that and now it works.

Ah, that makes sense, @erkdonovan. Thank you for clarifying that for me.