Domain Setup issue

“A DNS zone for this domain already exists on NS1” error trying to create DNS zone “

I’m just having trouble getting started!
My domain is currently registered at squarespace. I wasn’t sure if I should delete the default records, or just leave everything alone. I tried one Netlify site and it wasn’t working, so I read some articles and some folks said deleting and starting from scratch works, so I tried that.

This time, I added the suggested cname from Netlify on my squarespace domain settings ( Squarespace says “there can not be an apex (@) cname record”.

Hi, @davidlowh and welcome to our Netlify community site.

Squarespace uses the same DNS hosting service as we do and that DNS host (NS1) does not allow your domain to be configured twice on their service, no matter what.

So unfortunately, there is no straightforward migration path.

The best solution I know is to:

  1. Transfer to someplace like your registrar or Cloudflare that has free DNS hosting
  2. Work with Squarespace to remove the zone from NS1 (really! just removing your account may not be enough!)
  3. Ping us to confirm that it is gone (we can check before you make any other changes)
  4. Move to our DNS hosting if that check comes back successful.

Also, you do not have to use our DNS service to host your website at Netlify. You can also configure other DNS hosts and it can work quite well:

Regarding, the second error, it would seem that they do not allow a CNAME record on the apex/root domain (many DNS service do not as this is not an official DNS record type). However, many services to allow an ALIAS or ANAME record instead (which are unofficial but very useful types of DNS records - so many services to support them).

If an ALIAS/ANAME isn’t allowed, our documentation recommend using an A record for the apex domain which points to Netlify’s load balancer IP address. Quoting the documentation link above:

If your DNS provider does not support CNAME-style resolution for apex domains , you must configure your domain with a single-server A record:

  1. Find your DNS provider’s DNS record settings for your apex domain, such as .
  2. Add an A record . Depending on your provider, leave the host field empty or enter @ .
  3. Point the record to Netlify’s load balancer IP address: .
  4. Save your settings. It may take a full day for the settings to propagate across the global Domain Name System.

​Please let us know if there are other questions and we’ll be happy to answer.

Hi Luke,

Thanks for your reply!

I followed your advice and completed steps 1-4.

I also deleted the Netlify project and started a new one from scratch. I’m seeing some hopeful changes:

-under HTTPS under Domain Management, DNS verification was successful.

-When I click “check DNS configuration” next to my custom domains, the modal now gives me 4 nameservers to add to my domain provider. I’ve added these and looks like I may have to wait 24 hours.

However, I am seeing some other nameservers (which I can’t edit) on my cloudflare dashboard. Attaching a screenshot, please let me know if you think these defaults shouldn’t be an issue!

you cannot use cloudflare AND us for DNS. you’ll want to update the nameserver records at your registrar, and not use cloudlfare’s DNS (or remove the netlify DNS config and just use cloudflare for DNS instead).

If you do end up staying at cloudflare, please update your config for the bare domain and www to a supported configuration:

Maybe I’m the Fool here!

My SSL certificate has been enabled, though other things still aren’t clicking. Regarding assigning DNS to only one provider, I would love to do that! I didn’t do that on purpose, just trying to reconcile these things:

  1. cloudflare has given me DNS settings that apparently I can’t change - shown in image above
  2. I am trying to follow cues from Netlify - which said “make sure your nameservers are set to the following…”

Hmm, it looks like you genuinely did buy the domain from cloudflare - that’s a first. Most people just use them for DNS. You’d have to either:

  1. work with their support team to update the nameservers list to the list shown in our UI.
  2. However, there is no requirement that you use our DNS hosting, so I’d suggest you don’t use our DNS - you can deactivate it here:

…and then in cloudflare you’ll keep the A and CNAME, but uncheck the “orange cloud” as shown in your screenshot.

Ok I tried it!

Still getting an error page when trying to load the site, though.

However, it’s not showing any warnings here now:
(before was yellow sign with “check DNS configuration”)

Should I start waiting for 24 hours for this process to sort itself out?

I just reset my TTL to 2 minutes in cloudflare, let’s see if that makes a difference

Still don’t have a website. Anybody has a clue for me? Let me know if I can share more helpful screenshots for reference, thank you.

One option that’s a bit of a work-around but may still work, depending on your needs:

  1. Continue using Cloudflare for your primary DNS
  2. Make sure your netlify site is setup to be hosted at (or or whatever, but we’ll go with www for this example)
  3. In Cloudflare, add NS records for the www subdomain to point Netlify’s nameservers
  4. Use a Cloudflare rule to redirect browsers from ->
  5. ??
  6. Profit

Thanks Jaxidian,

I looked into setting custom nameservers on Cloudflare, but they want me to start paying (business plan at $200/month).

Also - I looked at options to transfer the domain registry again, but an article says that icann restricts successive domain transfers for a 60 day period.

For the time being, I’m stuck with Cloudflare and will keep trying to wrangle it however possible.

I’ll look into it your suggestion about using rules, and get back to you!

You don’t want “Custom nameservers”, you just need to add “NS” records (alternative to A or CNAME records). This should be free. Set these to netlify’s nameservers (it’ll be like you’re adding duplicate NS records, which is valid).

Previously, I did add netlify NS (1-4), which is in this screenshot.

Even after adding Netlify’s NS records, Cloudflare has 2 NS records (at bottom of screenshot) - which I can’t change without paying for a Business account apparently.

You said duplicate NS records shouldn’t cause a problem, so I’ll try it again and wait 24 hours.

Here’s what it looks like after I added the Netlify NS’s

Don’t add the NS record on the root, add it for www.

Ok thanks! I tried that, and got a warning. CNAME is using the www name

Yeah, kill the CNAME first. Once you set NS records to Netlify, they’ll take care of all of the DNS for you on www.

Go for something like this:

Done! Here’s what Netlify now looks like

should I be concerned about the warning to check DNS configuration on (It says I should update CNAME to www and - which Cloudflare won’t let me do)

Does this fall into the category of ‘wait 24 hours for propagation’?

I got that for a few minutes when I did this for my blog (“words” is the subdomain I went with). You shouldn’t have to wait nearly that long.

Ok, I just checked again and it looks the same, will update you tomorrow. Thanks for the advice!!

1 Like