Different behaviour after deploy

Hi, this is the problematic app: https://cesare-polonara.netlify.app/

Navigate to Projects section, by clicking on the thumbnails on the left, it renders a webpage on the iframe on the right.

Running it locally it behaves correctly . After deployment, if you click on the last thumbnail, it gets stuck and it graphically overlays over the others, I tried to disable the background of the incriminated app and you can see that it overlays, because the other ones get loaded behind and you can interact with them, but graphically that one gets stuck on the foreground…

Locally it works as expected, on click, it just renders a new source on the iframe, so I am lead to think it’s a problem with the netlify platform.

The only difference amongst that source and the other ones is that all the others are hosted on netlify, that one is hosted on glitch .


Hi @Kais3rP, welcome to the community!

I checked your site and while it took quite a bit of time for the Glitch app to wake up, I was not able to reproduce the issue you mentioned. Did you see any errors in the browser dev tools console? If so, can you share those errors? That would help point us in the right direction on where the issue might be.

Thanks for the answer, the issue is browser-related, specifically to Avast Browser, still not sure the reason, but it works fine on other chromium based browsers.

Ah, perhaps Avast Browser has a more strict CSP setting and does not allow iframes from a different domain.

It’s quite weird because it loads, and it works fine, but it just makes impossible to change the source after that it has been rendered there. Pretty weird :slight_smile: