Deployment issues, Rendering blank page

I’m trying to deploy a site i built using create-react-app but i can’t see my site deployed because it shows a blank page.
Using the netlify cli on terminal to deploy and the draft site name is:
the site works on github and deploys fine but for some reason it doesn’t here.
This is the github repo for the site


Hi there,

Did you see this guide yet? This is the best place to start for “Page Not Found” issues.

If you are still seeing issues after following the troubleshooting steps in this guide, please let us know!

1 Like

It seems like the links to your resources are off, there are errors for almost all of them:

That being said, some code is deployed, just not at the path where you’re trying to fetch it:


I hope that helps to investigate the problem.

1 Like

Thanks I read it before trying to deploy but the problem was from my package.json file. had to change homepage to “./” for it to work. I’m relatively new to development so I don’t fully understand why it was that way.
This is the deployed site

Yes I noticed that too. Was confused why it wasn’t
fetching from the right path. But I fixed it finally.
To be honest, I’m still not fully understanding why just changing
homepage to “./” in my package.json file was enough to fix it.

I’m glad you got it working now!

1 Like

I also seem to just be getting a blank page - how do I check for errors on netlify? There are none on my terminal locally. It has deployed fine?

hi there, did you check the post linked above? was it helpful at all?