Deploy going live but changes not seen on hosted webpage


I’ve been using netlify for a few years now. At first, I started manually making deployments by dragging the main index.xml file I use for my website.

Last year, I linked Netlify to my github for live deploys. It worked perfectly last year. However, this year I want to update my website and I don’t seem to be able to. The website gets deployed no issue with the changes I made but when I go to the website perse the changes are not there and the old version still stands with no update to be seen.

You can see the deploy details below

12:42:44 PM: Build ready to start

12:42:45 PM: build-image version: 8e315e54bc4032a32e73290be556cde4f8348c12

12:42:45 PM: build-image tag: v2.8.2

12:42:45 PM: buildbot version: 76af94f42647b2019c5925a515cc8332b4883b85

12:42:45 PM: Fetching cached dependencies

12:42:46 PM: Starting to download cache of 340.0MB

12:42:48 PM: Finished downloading cache in 3.002804561s

12:42:48 PM: Starting to extract cache

12:42:53 PM: Finished extracting cache in 4.240506333s

12:42:53 PM: Finished fetching cache in 7.384008538s

12:42:53 PM: Starting to prepare the repo for build

12:42:53 PM: Preparing Git Reference refs/heads/master

12:42:54 PM: Starting build script

12:42:54 PM: Installing dependencies

12:42:55 PM: Started restoring cached node version

12:42:57 PM: Finished restoring cached node version

12:42:58 PM: v10.23.2 is already installed.

12:42:58 PM: Now using node v10.23.2 (npm v6.14.10)

12:42:59 PM: Attempting ruby version 2.6.2, read from environment

12:43:00 PM: Using ruby version 2.6.2

12:43:00 PM: Using PHP version 5.6

12:43:00 PM: Started restoring cached go cache

12:43:00 PM: Finished restoring cached go cache

12:43:00 PM: unset GOOS;

12:43:00 PM: unset GOARCH;

12:43:00 PM: export GOROOT=’/opt/buildhome/.gimme/versions/go1.12.linux.amd64’;

12:43:00 PM: export PATH="/opt/buildhome/.gimme/versions/go1.12.linux.amd64/bin:${PATH}";

12:43:00 PM: go version >&2;

12:43:00 PM: export GIMME_ENV=’/opt/buildhome/.gimme/env/go1.12.linux.amd64.env’;

12:43:00 PM: go version go1.12 linux/amd64

12:43:00 PM: Installing missing commands

12:43:00 PM: Verify run directory

12:43:00 PM: Executing user command: hugo

12:43:00 PM: Started building sites …

12:43:01 PM: Built site for language en:

12:43:01 PM: 0 of 1 draft rendered

12:43:01 PM: 0 future content

12:43:01 PM: 0 expired content

12:43:01 PM: 3 pages created

12:43:01 PM: 0 non-page files copied

12:43:01 PM: 0 paginator pages created

12:43:01 PM: 3 tags created

12:43:01 PM: 1 categories created

12:43:01 PM: total in 190 ms

12:43:01 PM: Skipping functions preparation step: no functions directory set

12:43:01 PM: Caching artifacts

12:43:01 PM: Started saving pip cache

12:43:01 PM: Finished saving pip cache

12:43:01 PM: Started saving emacs cask dependencies

12:43:01 PM: Finished saving emacs cask dependencies

12:43:01 PM: Started saving maven dependencies

12:43:01 PM: Finished saving maven dependencies

12:43:01 PM: Started saving boot dependencies

12:43:01 PM: Finished saving boot dependencies

12:43:01 PM: Started saving go dependencies

12:43:01 PM: Finished saving go dependencies

12:43:01 PM: Build script success

12:43:01 PM: Starting to deploy site from ‘public’

12:43:01 PM: Creating deploy tree

12:43:01 PM: Creating deploy upload records

12:43:01 PM: 0 new files to upload

12:43:01 PM: 0 new functions to upload

12:43:01 PM: Starting post processing

12:43:01 PM: Post processing - HTML

12:43:01 PM: Post processing - header rules

12:43:01 PM: Post processing - redirect rules

12:43:01 PM: Post processing done

12:43:01 PM: Site is live :sparkles:

12:43:29 PM: Finished processing build request in 43.784956187s

Any leads?

Hi, @stapial. In most cases, the root cause is that the deploy isn’t including the changes as expected for some reason. In other words, we are hosting the files from the deploy correctly and it is the deploy itself which is not creating the correct files.

So, before we troubleshoot further, would you please download the deploy from Netlify. This is done on the deploy details page in our web UI using the button in the screenshot below:


Would you please download the deploy and let us know if the changes are showing in those files or not?

If the changes are not in those files, the next step is troubleshooting the build processes. However, if the correct files as shown in the deploy, please let us know and something else must be the root cause.

Hi @luke

Thank you for taking the time to respond to this. I downloaded the deploy and the changes are not to be seen in those downloaded files. I tried clearing cache and deploying but that did not work either.


Hi, @stapial. Thanks for checking on that. Now, the troubleshooting is more focused. We are not looking for stale content in the cache being served.

We are instead looking at the build process itself to find out why the build at Netlify doesn’t contain the updates. It is still “broken” but we are narrowing down the location of the “break”.

I see you are using Hugo and using our default version. You are probably using a much newer version of Hugo locally. You can change the version we use in the build at Netlify by setting a HUGO_VERSION environment variable at Netlify.

The environment variable settings are found in our web UI under Site Name > Settings > Build & deploy > Environment.


Would you try adding that and let us know if that fixes it?