Deploy failed for earnest-cupcake-95c291

Good afternoon. Tried severally to deploy and it keeps failing. Kindly need your help

Find below the failed log. Also attached is a screenshot

10:25:45 AM: Failing build: Failed to parse configuration
10:25:45 AM: Failed during stage ‘Reading and parsing configuration files’:
When resolving config:
Base directory does not exist: /opt/build/repo/0e406ae76ad4ce1488724f2ef29c40b222ab0a6e

hi there, welcome.

my hunch at the moment is that something is wrong with your package.json file.

Could you share the contents here please or link us to it so we can see it?

Thank you Perry. Glad to be here.

Would you want me to share my GitHub repository link for this or just portion of that link?

It is public anyway.

Link: FlikonTV/campustvtour (github.com)

10:25:35 AM: Build ready to start

10:25:43 AM: build-image version: d2c6dbeac570350a387d832f64bc980dc964ad65 (focal)

10:25:43 AM: build-image tag: v4.8.0

10:25:43 AM: buildbot version: 29e546ddee264a16af472b38ccba15b350150213

10:25:43 AM: Fetching cached dependencies

10:25:43 AM: Failed to fetch cache, continuing with build

10:25:43 AM: Starting to prepare the repo for build

10:25:43 AM: No cached dependencies found. Cloning fresh repo

10:25:43 AM: git clone GitHub - FlikonTV/campustvtour

10:25:44 AM: Preparing Git Reference refs/heads/main

10:25:44 AM: Parsing package.json dependencies

10:25:44 AM: Creating deploy upload records

10:25:45 AM: Failing build: Failed to parse configuration

10:25:45 AM: Failed during stage ‘Reading and parsing configuration files’:
When resolving config:
Base directory does not exist: /opt/build/repo/0e406ae76ad4ce1488724f2ef29c40b222ab0a6e

: exit status 1

10:25:45 AM: Finished processing build request in 2.111126442s

can you pop a screenshot of our build settings (from the netlify UI) for us? i think that this line is gonna help us sleuth:

10:25:45 AM: Failed during stage ‘Reading and parsing configuration files’:
When resolving config:
Base directory does not exist: /opt/build/repo/0e406ae76ad4ce1488724f2ef29c40b222ab0a6e

maybe you have a wonky directory or something similar in the settings in the UI.

Sure Perry.

I hope its the right screenshot. Forgive me. Am new here.

i actually meant this URL (replace the sitename)

https://app.netlify.com/sites/[YOUR SITE NAME]/settings/deploys

edited as i had the wrong link myself!

this is the stuff i want to see for your site: (this is from one of ours)

Oh! Great. Here it is

https://app.netlify.com/sites/earnest-cupcake-95c291/settings/deploys

ah. here’s the culprit as expected. that long number sequence is not the appropriate directory.

i think that your base directory can be “not set” and your publish directory - hmm, lets try public/. i’m not a super expert on what all the different frameworks require but this is definitely the problem.

This is what returns Perry when i input “not set” in the base directory. It automatically sets the publish directory as “not set” / dist/ . See below

oh, i meant to just leave it blank! can you try that? I should have been more specific in my language.

:laughing: will try that now and let you know. Thanks a lot

1 Like

You were almost right. Went far but still encountered a Configuration error

Error message: Deploy did not succeed: Deploy directory ‘dist’ does not exist

Hey @cihanmedia

From the webpack.config.js in the repository

    path: path.resolve(__dirname, "./build"),

Which means it is building to build, not dist

1 Like

thank you coel! @cihanmedia - we were so close. change the directory to build, not dist, and it should work!

Thank you @perry and @coelmay

Site was successfully deployed but with a little snag. It dispolayed the 404 error page.

earnest-cupcake-95c291’s 100ms Teacher App

This is something internal to your app routing. If it was a 404 served by Netlify, it would look like this

Do you have a redirect for an SPA configured?

As it appears you have now made the repository private, it makes it hard to offer any code-specific assistance.

Meanungful morning @coelmay, started over again with hope to fix it. Got to the same point of “404 Invalid URL!”

However, I have made the repository public as advised. Would appreciate your further help. Thanks so much - FlikonTV/ctvvirtualtour (github.com)

Looking at the README @cihanmedia it says

The app now should be running at https://localhost:3000/. (Please ignore the 404 message, you need to join the right URL of the room. Next sections describe how to create a room and form the correct URL)

It would appear there is no “homepage” as it were. It goes on to says

Visit the URL : https://localhost:3000/meeting/<room_id>/< role > to join the room

So I typed in a random room number and received:

If you would like to have something other than a 404 message shown on the “homepage” (or site root) it seems you will need to add that functionality yourself (without affecting the current functionality of the site.)