Deploy doesn't update

I have tried to deploy my sites after updating my work. I keep getting the old results even after deployment. Below is the deploy log…I really need help with this. This is also link to my github repo:

It works well when i run it on my vs studio and github.

This is how it is supposed to display

But this is how it displays

6:14:29 AM: build-image version: 3b96229e32b19cdf63f20dc1fc9331cd240c2d01 (focal)
6:14:29 AM: buildbot version: 3b96229e32b19cdf63f20dc1fc9331cd240c2d01
6:14:29 AM: Fetching cached dependencies
6:14:29 AM: Failed to fetch cache, continuing with build
6:14:29 AM: Starting to prepare the repo for build
6:14:29 AM: No cached dependencies found. Cloning fresh repo
6:14:29 AM: git clone --filter=blob:none GitHub - shashabella/Vanilla-Style-Weather-App
6:14:29 AM: Preparing Git Reference refs/heads/main
6:14:31 AM: Starting to install dependencies
6:14:31 AM: Python version set to 3.8
6:14:31 AM: Attempting Ruby version 2.7.2, read from environment
6:14:32 AM: Using Ruby version 2.7.2
6:14:33 AM: Started restoring cached go cache
6:14:33 AM: Finished restoring cached go cache
6:14:33 AM: go version go1.19.10 linux/amd64
6:14:33 AM: Using PHP version 8.0
6:14:34 AM: v18.16.0 is already installed.
6:14:35 AM: Now using node v18.16.0 (npm v9.5.1)
6:14:36 AM: Starting post processing
6:14:35 AM: Enabling Node.js Corepack
6:14:35 AM: Started restoring cached build plugins
6:14:36 AM: Skipping HTML post processing
6:14:35 AM: Finished restoring cached build plugins
6:14:35 AM: Install dependencies script success
6:14:35 AM: No build steps found, continuing to publishing
6:14:35 AM: Starting to deploy site from ‘/’
6:14:35 AM: Calculating files to upload
6:14:35 AM: 0 new files to upload
6:14:35 AM: 0 new functions to upload
6:14:35 AM: Section completed: deploying
6:14:35 AM: Section completed: building
6:14:35 AM: Uploading Cache of size 9.5KB
6:14:35 AM: Section completed: cleanup
6:14:35 AM: Finished processing build request in 6.642s
6:14:38 AM: Post processing - header rules
6:14:39 AM: Post processing - redirect rules
6:14:40 AM: Post processing done
6:14:41 AM: Section completed: postprocessing
6:14:42 AM: Site is live :sparkles:

did you tell Netlify where to build your site? Can you share a screenshot of your build settings?

No I don’t think so. This is the screenshot

@shashabella The build indicates that it hasn’t detected any changed files.
Are you sure that you’ve uploaded changed files?

6:14:35 AM: Calculating files to upload
6:14:35 AM: 0 new files to upload
6:14:35 AM: 0 new functions to upload

Ignoring your upload troubles, your app isn’t working because it’s calling an API URL that doesn’t exist.
A mixed up version of your Site URL and the API URL:

If you check the related code you can see that the URL is malformed:

You should fix the URL to start with https://

1 Like

@nathanmartin Thank you so much. It worked! I fixed the https error like you indicated and it is now running like I want it to. Thank you for your support

@SamO thanks for your support in trying to resolve the issue. It has been resolved by @nathanmartin.