Deploy a Strapi and React Blog on Netlify

Hi,

in your tutorial: Learn How To Deploy a Strapi-Powered React Blog to Netlify, you write: “On the next screen, add your API_URL, which is the URL of your Strapi instance running on Heroku (e.g. https://your-strapi-app.herokuapp.com), without the trailing slash”.

There is no API_URL on the next screen. Please note screenshot below for reference.

Please help with a solution to this problem.

Thank you.

It’s probably because it’s a different starter or something might have changed after the post was written.

However, you can later add an Environment Variable in settings of the app. So you can go ahead and create a website to start with.

Thank you for your answer however it doesn’t solve my problem. If the tutorial is misleading it needs to be corrected.

Could you be more specific, where should I add the Environment Variable, which settings of the app are you referring to?

Thank you.

As I said, the tutorial talks about React and not Gatsby. You’re using a different setup.

I’m talking about the settings here:

image

Here: https://app.netlify.com/sites/<site-name>/settings/deploys#environment

1 Like

I am not using a different setup. I’m following the tutorial step by step as instructed.

Again: the tutorial is misleading it talks about react but then the starter is a Gatsby Starter. If you click the link: https://app.netlify.com/start/deploy?repository=https://github.com/strapi/strapi-starter-gatsby-blog&_ga=2.233689368.703861225.1611673048-1967964031.1608657738 you will notice it’s a Gatsby starter.

What matters is that the tutorial has false information and is misleading users like me, that want to use this functionality but are unable to because the tutorial has errors.

What should I enter in Key and value?

Thank you.

Key should be API_URL and the value should be the Heroku URL.

1 Like