create-React-app not deploying. Using craco

My site is: romantic-newton-ef1c5d

my deployment log:

10:16:45 PM: Build ready to start
10:16:47 PM: build-image version: 3571f0130496395a23bffe9820bc78b4f73a6234
10:16:47 PM: build-image tag: v3.7.0
10:16:47 PM: buildbot version: 945e22ac61fb3a0e5ec8bebfe91c852809f9f21b
10:16:47 PM: Fetching cached dependencies
10:16:47 PM: Failed to fetch cache, continuing with build
10:16:47 PM: Starting to prepare the repo for build
10:16:48 PM: No cached dependencies found. Cloning fresh repo
10:16:48 PM: git clone GitHub - Eflores2099/new-portfolio
10:16:49 PM: Preparing Git Reference refs/heads/main
10:16:50 PM: Parsing package.json dependencies
10:16:51 PM: Different build dir detected, going to use the one specified in the Netlify configuration file: ‘’ versus ‘./’ in the Netlify UI
10:16:52 PM: Starting build script
10:16:52 PM: Installing dependencies
10:16:52 PM: Python version set to 2.7
10:16:54 PM: v12.18.0 is already installed.
10:16:55 PM: Now using node v12.18.0 (npm v6.14.4)
10:16:55 PM: Started restoring cached build plugins
10:16:55 PM: Finished restoring cached build plugins
10:16:56 PM: Attempting ruby version 2.7.1, read from environment
10:16:58 PM: Using ruby version 2.7.1
10:16:59 PM: Using PHP version 5.6
10:16:59 PM: Started restoring cached yarn cache
10:16:59 PM: Finished restoring cached yarn cache
10:16:59 PM: Installing yarn at version 1.22.4
10:16:59 PM: Installing Yarn!
10:16:59 PM: > Downloading tarball…
10:16:59 PM: [1/2]: https://yarnpkg.com/downloads/1.22.4/yarn-v1.22.4.tar.gz → /tmp/yarn.tar.gz.n6ETc0qHs2
10:16:59 PM: % Total % Received % Xferd Average Speed Time Time Time Current
10:16:59 PM: Dload Upload Total Spent Left Speed
10:16:59 PM: 0 0 0 0 0 0 0 0 --:–:-- --:–:-- --:–:-- 0
10:16:59 PM: 100 79 100 79 0 0 313 0 --:–:-- --:–:-- --:–:-- 314
10:16:59 PM: 100 93 100 93 0 0 162 0 --:–:-- --:–:-- --:–:-- 162
10:17:00 PM: 0 0 0 0 0 0 0 0 --:–:-- --:–:-- --:–:-- 0
10:17:00 PM: 100 625 100 625 0 0 638 0 --:–:-- --:–:-- --:–:-- 3063
10:17:00 PM: 100 1215k 100 1215k 0 0 832k 0 0:00:01 0:00:01 --:–:-- 832k
10:17:00 PM: [2/2]: https://yarnpkg.com/downloads/1.22.4/yarn-v1.22.4.tar.gz.asc → /tmp/yarn.tar.gz.n6ETc0qHs2.asc
10:17:00 PM: 100 83 100 83 0 0 1677 0 --:–:-- --:–:-- --:–:-- 1677
10:17:00 PM: 100 97 100 97 0 0 1244 0 --:–:-- --:–:-- --:–:-- 1244
10:17:00 PM: 100 629 100 629 0 0 5744 0 --:–:-- --:–:-- --:–:-- 5744
10:17:00 PM: 100 1028 100 1028 0 0 7419 0 --:–:-- --:–:-- --:–:-- 7419
10:17:01 PM: > Verifying integrity…
10:17:01 PM: gpg: Signature made Mon 09 Mar 2020 03:52:13 PM UTC using RSA key ID 69475BAA
10:17:01 PM: gpg: Good signature from “Yarn Packaging yarn@dan.cx
10:17:01 PM: gpg: WARNING: This key is not certified with a trusted signature!
10:17:01 PM: gpg: There is no indication that the signature belongs to the owner.
10:17:01 PM: Primary key fingerprint: 72EC F46A 56B4 AD39 C907 BBB7 1646 B01B 86E5 0310
10:17:01 PM: Subkey fingerprint: 6D98 490C 6F1A CDDD 448E 4595 4F77 6793 6947 5BAA
10:17:01 PM: > GPG signature looks good
10:17:01 PM: > Extracting to ~/.yarn…
10:17:01 PM: > Adding to $PATH…
10:17:01 PM: > Successfully installed Yarn 1.22.4! Please open another terminal where the yarn command will now be available.
10:17:01 PM: Started restoring cached node modules
10:17:01 PM: Finished restoring cached node modules
10:17:02 PM: Installing NPM modules using Yarn version 1.22.4
10:17:03 PM: yarn install v1.22.4
10:17:03 PM: warning package-lock.json found. Your project contains lock files generated by tools other than Yarn. It is advised not to mix package managers in order to avoid resolution inconsistencies caused by unsynchronized lock files. To clear this warning, remove package-lock.json.
10:17:03 PM: [1/4] Resolving packages…
10:17:04 PM: [2/4] Fetching packages…
10:17:40 PM: info fsevents@2.3.1: The platform “linux” is incompatible with this module.
10:17:40 PM: info “fsevents@2.3.1” is an optional dependency and failed compatibility check. Excluding it from installation.
10:17:40 PM: info fsevents@1.2.13: The platform “linux” is incompatible with this module.
10:17:40 PM: info “fsevents@1.2.13” is an optional dependency and failed compatibility check. Excluding it from installation.
10:17:40 PM: info fsevents@2.1.3: The platform “linux” is incompatible with this module.
10:17:40 PM: info “fsevents@2.1.3” is an optional dependency and failed compatibility check. Excluding it from installation.
10:17:40 PM: [3/4] Linking dependencies…
10:17:40 PM: warning " > @testing-library/user-event@12.6.2" has unmet peer dependency “@testing-library/dom@>=7.21.4”.
10:17:40 PM: warning “react-scripts > @typescript-eslint/eslint-plugin > tsutils@3.17.1” has unmet peer dependency “typescript@>=2.8.0 || >= 3.2.0-dev || >= 3.3.0-dev || >= 3.4.0-dev || >= 3.5.0-dev || >= 3.6.0-dev || >= 3.6.0-beta || >= 3.7.0-dev || >= 3.7.0-beta”.
10:18:00 PM: [4/4] Building fresh packages…
10:18:03 PM: success Saved lockfile.
10:18:03 PM: Done in 59.88s.
10:18:03 PM: NPM modules installed using Yarn
10:18:03 PM: Started restoring cached go cache
10:18:04 PM: Finished restoring cached go cache
10:18:04 PM: go version go1.14.4 linux/amd64
10:18:04 PM: go version go1.14.4 linux/amd64
10:18:04 PM: Installing missing commands
10:18:04 PM: Verify run directory
10:18:07 PM: ​
10:18:07 PM: ────────────────────────────────────────────────────────────────
10:18:07 PM: Netlify Build
10:18:07 PM: ────────────────────────────────────────────────────────────────
10:18:07 PM: ​
10:18:07 PM: ❯ Version
10:18:07 PM: @netlify/build 9.13.0
10:18:07 PM: ​
10:18:07 PM: ❯ Flags
10:18:07 PM: apiHost: api.netlify.com
10:18:07 PM: cacheDir: /opt/build/cache
10:18:07 PM: deployId: 605abd2db96f014b1a5cd361
10:18:07 PM: mode: buildbot
10:18:07 PM: testOpts:
10:18:07 PM: silentLingeringProcesses: ‘’
10:18:07 PM: ​
10:18:07 PM: ❯ Current directory
10:18:07 PM: /opt/build/repo
10:18:07 PM: ​
10:18:07 PM: ❯ Config file
10:18:07 PM: No config file was defined: using default values.
10:18:07 PM: ​
10:18:07 PM: ❯ Context
10:18:07 PM: production
10:18:07 PM: ​
10:18:07 PM: ────────────────────────────────────────────────────────────────
10:18:07 PM: 1. Build command from Netlify app
10:18:07 PM: ────────────────────────────────────────────────────────────────
10:18:07 PM: ​
10:18:07 PM: $ npm run build
10:18:07 PM: > portfolio@0.1.0 build /opt/build/repo
10:18:07 PM: > craco start
10:18:13 PM: :information_source: 「wds」: Project is running at http://10.7.188.207/
10:18:13 PM: :information_source: 「wds」: webpack output is served from
10:18:13 PM: :information_source: 「wds」: Content not from webpack is served from /opt/build/repo/public
10:18:13 PM: :information_source: 「wds」: 404s will fallback to /
10:18:13 PM: Starting the development server…
10:18:13 PM:
10:18:50 PM: Compiled successfully!
10:18:50 PM: You can now view portfolio in the browser.
10:18:50 PM: Local: http://localhost:3000
10:18:50 PM: On Your Network: http://10.7.188.207:3000
10:18:50 PM: Note that the development build is not optimized.
10:18:50 PM: To create a production build, use yarn build.
10:46:45 PM: Build exceeded maximum allowed runtime
10:46:47 PM: Failed to compile.
10:46:47 PM:
10:46:47 PM: ./src/index.js
10:46:47 PM: Error: ENOENT: no such file or directory, open ‘/opt/build/repo/src/index.js’

I’ve deployed a site but it no longer updates when I push up to github (yes I know about auto publishing) The log is pointing to the index.js file but I’m not sure what I’m looking for. I should also add that I’m using craco in my scripts in my package JSON because I’m using TailwindCSS.

My scripts look like this:

"start": "craco start" , "build": "craco build", "test": "craco test", "eject": "react-scripts eject"

Anyone have ideas? Thanks.

You seem to be starting a development build, which is running a server. Thus, the build is eventually timing out.

You need to run a production build, something that will finish the build process and generate static HTML, CSS, JS files.

This article might help: Netlify Deployment config settings for craco react apps. - DEV Community

TLDR; change your build settings to npm run build instead of craco build