Could not find module "@parcel/transformer-webmanifest"

I have an app deployed on Netlify. It’s been working fine for a while, but now I wanted to add a web manifest which needs the package @parcel/transformer-webmanifest".

After many hours, I have been unable to get past this error:

🚨 Build failed.
11:27:57 PM: @parcel/package-manager: Could not find module "@parcel/transformer-webmanifest"
11:27:57 PM: satisfying 2.3.1.
11:27:57 PM:   /opt/build/repo/package.json:17:5
11:27:57 PM:     16 |   "dependencies": {
11:27:57 PM:   > 17 |     "@parcel/transformer-webmanifest": "^2.3.2",
11:27:57 PM:   >    |     ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ Found this conflicting local requirement.
11:27:57 PM:     18 |     "@parcel/transformer-elm": "^2.3.1",
11:27:57 PM:     19 |     "bootstrap-icons": "^1.8.1",
11:27:57 PM: ​
11:27:57 PM: ────────────────────────────────────────────────────────────────
11:27:57 PM:   "build.command" failed                                        
11:27:57 PM: ────────────────────────────────────────────────────────────────

It’s entirely unclear to me why that is; this works fine locally, on
Digital Ocean, and on Firebase. Why can’t Elm find this package?

Edit: I tried lowering the version to match the parcel version (2.3.1) but that didn’t change anything.

This doc is our best guidance on debugging builds in general:

  • could you take a look and try the steps in there? If that didn’t help, it’s always best to link us to your deploy logs in the UI so we can look in more depth - mind providing a link to your latest build if it is still failing, and answer the other questions about what else you tried (and what happened when you did) that are at the end of that article as far as next steps after you’ve tried following it?


Hey, thanks for taking a look. I spent a lot of time on this but it ended up getting fixed by just upgrading parcel.

1 Like

thanks for letting us know! that might help someone else for sure.