CORS Error - Request had target IP address space of `unknown`

In my spa application, i get a cors error printed in the console claiming “Request had a target IP address space of unknown yet the resource is in address space public.”

My website is built with create-react-app. A clearer illustration of the error is shown in the image below. Here is the link to the website that generates this error

In the error, i can see the origin is the same and i do not understand reasons why it is blocked by CORS policy. The weird gotchas is that at times the the CORS Error is generated and at times things just work fine. But it sure annoys me when my website is not guaranteed to run error-free always.

Hey @smitter,

I tried to reload multiple times, and I do not see this error. Is it fixed?

Hello :wave:,

Well it’s pretty difficult to tell when It’s going to err. Because the kind of error is the one that sometimes happens and at times things are up and running normally. From the time I posted I have run into the same error once.
After redeployment I am still yet to run into the same issue.

Thanks for the follow-up @smitter. If you do run into the issue again, please let us know and let us know the steps to reproduce the error. Thanks!