Connection refused for one DNS record but not the other

I created a new site in the last few days ( and it is successfully deploying at one DNS record but not the other. I’m using a custom domain from GoDaddy, but Netlify is managing DNS and I changed the nameservers accordingly. There is no indication on Netlify that anything is going wrong with my deployment or with the domains.

When I go to my site at, everything looks fine. However, when I go to, I see either ERR_CONNECTION_CLOSED or a GoDaddy page – although if I switch from Chrome to Safari both domains seem to be working. I’ve tried clearing my browsing history on Chrome but I still have this problem.

When I first set up my custom domain on Netlify yesterday, I was also having this problem. Then it seemed to fix itself, so I assumed it was a timing issue with the nameservers/DNS initial setup. But now it’s happening again, and since I don’t see any errors anywhere, I’m not sure how to begin troubleshooting.

@eamcvey Welcome to the Netlify community.

You may be seeing a local caching artifact, because each version loads fine for me in Southern California, and the bare custom domain redirects to the www custom subdomain as expected.

You might try checking using something like GTMetrix or a private / incognito browser window to further narrow down where the issue is on your end.

Hi, @eamcvey, my best guess is that the previous records are sometimes being returned because they are still cached by a DNS resolver. There is more about these issues here:

If you still get these errors, it would be helpful to know the following details to troubleshoot:

  • the resolver being queried (domain name or IP address)
  • the DNS record being queried (the domain name and record type)
  • the answer returned by the DNS resolver

​Please let us know if there are other questions and we’ll do our best to answer.