Command failed with exit code 1: npm run build (

I need help - my automatically build from GitHub doesn’t work.
I’ve tried to Google, search the support forums here and so on. Since I’m a newbie and haven’t got “tons of experience” in this area yet - I kindly ask you for help :slight_smile:

My deployed Netlify-site (that doesn’t work) has this URL:
(Netlify App)

  • DNS issues? Tell us the custom domain, tell us the error message! We can’t help if we don’t know your domain.
    Yeah - the custom domain is as mentioned above - but I’ve experienced ZERO issues with this in the past… I’ve always been able to deploy to Netlify and after that change the domain name and it has worked like a charm!

  • Build problems? Link or paste the FULL build log & build settings screenshot
    Yesssss - here is the part of the deploy log with issues (apparently I couldn’t paste the full deploy log here because I’m a new member here on the forum…):

The errors starts to show up from line 77 and below, so I pasted that part below this part as well.
I’ve checked this module that it says it can’t find and as far as I can see the spelling is right and it is imported the way it should and so on.
This i driving me crazy! Any assistance on how to solve this will be highly appreciated.
Thanks in advance!
8:07:26 AM: Failed to compile.
8:07:26 AM:
8:07:26 AM: Module not found: Error: Can’t resolve ‘components/ToDoList/ToDoList’ in ‘/opt/build/repo/code/src’
8:07:26 AM: ​
8:07:26 AM: “build.command” failed
8:07:26 AM: ────────────────────────────────────────────────────────────────
8:07:26 AM: ​
8:07:26 AM: Error message
8:07:26 AM: Command failed with exit code 1: npm run build (Search results for '"non-zero exit code: 1"' - Netlify Support Forums)
8:07:26 AM: ​
8:07:26 AM: Error location
8:07:26 AM: In build.command from netlify.toml:
8:07:26 AM: npm run build
8:07:26 AM: ​
8:07:26 AM: Resolved config
8:07:26 AM: build:
8:07:26 AM: base: /opt/build/repo/code
8:07:26 AM: command: npm run build
8:07:26 AM: commandOrigin: config
8:07:26 AM: publish: /opt/build/repo/code/build
8:07:26 AM: publishOrigin: config

Without seeing the build log (please, no screenshots; post a link to the build log) and repository, at a guess I might say the issue is case sensitivity

1 Like

I see your most recent deploy was successful. Please let us know if you are in need of further assistance.