CLI Build - Internal error during "options.onEnd"

Hi,

I am working on deploying my React app
( https://cravecrafter.netlify.app/ ) The backend is Django hosted on Railway.

#1 - The continuous deployment that is supposed to be happening since the code is connected with my GitHub has not been working. I have been trying to update my code to get it linked up to my hosted API instead, but no updates are going through. I realized even if I comment out all the code none of the code is changing, although it says that it has been updated every time I’ve pushed to GitHub.

#2 - In trying to debug this, I tried to do a manual build from the CLI. I received an error response that I have not found anywhere else online.

For context, the relevant parts of my file structure are as such:
.netlify/
|— state.json
(note there is no netlify.toml file here. I tried creating one but did not have permissions. I called sudo touch netlify.toml and it made the file visible but that continued with the same issues)
build/
|— static
|— asset-manifest.json
|— favicon.ico
|— index.html
node_modules/
public/
|— favicon.ico
|— index.html
src/
.env
.gitignore
package-lock.json
package.json

Thanks so much for your help! Let me know if you need anything else.

Hi, @sdutton27. The CLI issue is a file permission issue. It is unrelated to the build errors you are seeing at Netlify and so I’m not going to address it at this time.

For the build errors that occur during the site build, I’m seeing a message that says:

Treating warnings as errors because process.env.CI = true.
Most CI servers set it automatically.

Have you tried setting that environment variable to false?