Changes coming to Netlify site URLs: .com to .app

@fool any thoughts on this?

hi there, this sounds potentially related, but we might need to do some more investigating. thanks for bringing this to our attention.

We’ve sent you an email associated with your paid team to follow up on this.

Hiya @marcopchen and welcome to our community!

As I mentioned to @mtrias no changes to DNS should have been needed to accommodate this change. If you were somewhere OUTSIDE of DNS hardcoding the type path, you’d need to update that - e.g. in your Access-Control-Allow-Origin type HTTP headers for instance. If that doesn’t ring any bells, and you want to link us to your site we might be able to help debug further.

So, in our case, we were using a custom domain for our docs site (at ) and we pull content from it using AJAX in our app ( ). When Netlify made the domain change, our docs site started being redirected to Browsers where reporting a CORS headers problem, but the fix in our case was actually to change a CNAME record in our DNS servers to point to the proper place.

Commited changes in my .com are not reflecting again, why please? would redirect, thats fine, what about commited changes ? its like I have two domain names, the more updated and the less updated commited changes should reflect, kindly look into this please.

1 Like

Your issue is extremely unlikely to be related to this migration. Nonetheless, we’ll be happy to help you debug that other situation, if you’ll get us the value of the x-nf-request-id for some “stale” content you saw. This post describes how: [Support Guide] Netlify Support asked for the 'x-nf-request-id' header? What is it and how do I find it?

I used a custom domain, its fine now. Thanks!

FYI. I use and is on some sort of blacklist there.

1 Like

I seem to have lost my _redirects mojo. I’ve updated one of my redirects to read:* 301!

… but it’s not working. .com redirects to .app, but .app doesn’t redirect to my custom domain name.

I have also created a netlify.toml file with the equivalent redirect it in (using the Play feature), but no joy.

There used to be a “code” box – either in the docs or in the app dashboard – that showed the exact redirect needed to force visitors to the * site to the custom domain, but either it’s gone or I’m not finding it.

What am I missing?

there is no “”, Greg - only “”. Try updating that and I bet it works better!

The playground only says if there is a syntax error, not a semantics error like that…

We did indeed remove the “docs box” which was in app with that advice, since we do this now instead, to prevent the SEO hit from not so doing:

Sorry for the typo, but it still doesn’t work. Neither the nor the versions redirect to the custom domain name. At any rate, I’m currently unable to log into my Netlify dashboard so I can’t make any changes or corrections right now.

Never mind. This issue may be connected to a DNS setting on my end. When I switched from Cloudflare to NameCheap SafeServe as my public resolver, the redirects occur as expected.

We also had issues with CORS headers, specifically to a lambda function we use with a POST request as payment gateway. Because of the redirect, it stopped working completely because of CORS issues, we lost customers because of it!

Hi There ! First of all thanks for the awesome work :slight_smile: I’ve been deploying static website very easily thanks to netlify !
My app is located at (former and the transition you made was pretty smooth for new users. However we made a looot of updates these days and the users that had already visited my website before the transition can still find the former version of the website (not functional anymore :slight_smile: ) when they reach Is this due to a cache policy of some sort ? I receive a 304 from service worker. I can’t figure out how to prevent this behaviour for my current users.
(When I reach the website form a new private brower window, I indeed receive a 301 and everything works fine)

hey maxime, i just checked your URL and it seems to be forwarding as expected to when i try and access

are you still seeing something different?

Hi there ! Thanks for your rapid reply ! Yes, as I said in my previous comment, the issue I’m talking about only concerns people who already visited before the transition :slight_smile: (I would be honored if it was your case but I doubt it :wink: )

In this particular case, the user sees an older version of the website and I can’t update it anymore. When I inspect the network I see a 304 (“From service worker”) instead of the regular 301.

I’m using a custom domain, and not experiencing any issues.

However, I was wondering if there were plans to update the DNS settings to point to the canonical “.app” domain.

Right now, going to Settings > Domains > clicking my domain name, under “DNS Settings” the records of type “NETLIFY” both point to the “.com” versions of the URL and each say “This is a system record that cannot be managed directly.”

If there’s any way of forcing this to update, please let me know! Thanks.

Hello there, any news on this ? I’m still experiencing the issue

At a guess, your service worker is misbehaving; likely you have allowed it to be cached for too long (default is a day and that would have passed by now).

This isn’t a “direct” answer to your question, but more about a best practice on using service workers here:

It is unfortunately very hard to fix bad caching settings in retrospect - you basically need to entice visitors to visit some new page where you can deregister the badly cached version.

Sorry I don’t have better news for you today!

Hey guys, even though this has been done…and I just noticed the notification has been since February, it does affect some sites. Mainly those with CORS configs limiting the domains that can reach their servers. We only discovered this issue once our customers where unable to login. Although I’m not sure there’s any other way you could have notified us(as our account is a not controlled by the individual developers). Just wanted to state that…for the record